Help Please(Powerbook G3)

Discussion in 'PowerPC Macs' started by Austinw88, Apr 6, 2012.

  1. Austinw88
    Expand Collapse
    macrumors newbie

    Joined:
    Apr 6, 2012
    #1
    Ok, I have a powerbook g3 (firewire) I just got from a friend and its not working. The battery is charged because I bought a new charger for it and the light shows full charge. It comes on and you can hear the harddrive kick on the num locks lights up along with the caps lock button but there is no picture at all. I tried pluging it in to another monitor but still nothing. Can anyone help me?
     
  2. Ariii
    Expand Collapse
    macrumors 6502a

    Ariii

    Joined:
    Jan 26, 2012
    Location:
    Chicago
    #2
    Does it have OS X or OS 9? If you have either, you could take it from another computer and try booting from that on a flash drive. I only tried it on OS 9, though. If that works, then obviously the hard drive is the only problem.
     
  3. Austinw88
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Apr 6, 2012
    #3
    I'm not sure witch it has on it, the stickers dont say...
     
  4. martinws
    Expand Collapse
    macrumors newbie

    Joined:
    Nov 17, 2004
    Location:
    Dorset, UK
    #4
    It could be a dead PRAM battery. Try disconnecting it.
     
  5. Austinw88
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Apr 6, 2012
    #5
    I thought about that, But sense i'm new to apples I dont know where its located on them and I didnt want to break to far into it without knowing the location.
     
  6. martinws
    Expand Collapse
    macrumors newbie

    Joined:
    Nov 17, 2004
    Location:
    Dorset, UK
    #6
    It's pretty easy to disconnect the PRAM battery, see the iFixIt site.

    Looks like from step 3 you could just straight to step 8. A couple of minutes of work will see if the problem is that.
     
  7. Austinw88
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Apr 6, 2012
    #7
    Well that's easy thanks will found out soon if that's it...
     
  8. Austinw88
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Apr 6, 2012
    #8
    I tried the pram battery, still nothing... I dont know what to do with this thing.
     
  9. martinws
    Expand Collapse
    macrumors newbie

    Joined:
    Nov 17, 2004
    Location:
    Dorset, UK
    #9
  10. Austinw88
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Apr 6, 2012
    #10
    No luck on fixing the computer, Can someone tell me what it might be worth not working?
     

Share This Page