Help please!! (PowerBook G4 that is stuck on the grey screen)

Discussion in 'PowerPC Macs' started by violetsmom, Jul 9, 2011.

  1. macrumors newbie

    Jul 9, 2011
    Hi! I need help! I have a PowerBook G4 that is stuck on the grey screen with the annoying little spinning gear thingy. We have had this computer for a few years and it worked fine for awhile, then all of a sudden it would not connect to internet and kept saying "IP address not valid" or something like that and so we set it aside and didn't use it. Then, yesterday, I decided to try and get it to work so I looked around on line and someone suggested to turn the firewall to accept all feeds or something like that (and then turn firewall back as it was) and it worked!!! I was soooooooo excited!!!! Sooooo, of course after not having been on line for a year there were a ton of updates, 9 in all I believe, and so I did the updates, and now my computer will not boot up!! It just sits on the grey screen with that damned spinning gear!!! I have tried a few things I saw suggested on other threads, such as starting in safe mode or whatever, and some fsck thing, but nothing has worked. I have unplugged it, restarted it, nothing works!! I can't remember what all the updates are, itunes, safari, quicktime- can't remember anything else. I think this computer has ox (is that what it's called?) Also, I do not have any disk to restart the computer, as my brother-in-law gave us the computer when he upgraded the computers in his office. We have used it as an extra computer, and now that my ten year wants to be online ALL the time, we really would like to get it working. As you can tell, I am totally NOT computer techy-savy!!! I was so excited when I got the internet to work again and now this :( Any ideas??
  2. macrumors 65816


    Nov 17, 2008
    Cudi Zone
    Sounds like the hard disk is dying.

    IFixit should have the instructions on how to replace it.
  3. macrumors 68020


    Mar 13, 2005
    Could also be just common bitrot. It can get so bad at times that it renders some drives seemingly dead but it may just need a fresh format and install.

    If it gets to the spinning gear there is a chance it isn't dead.
  4. macrumors 6502


    Jan 16, 2010
    Does sound like the HD is dead but before buying a new HD try this:

    1. When you hear the startup chime hold down all together


    2. Open the computer and get to the front of the motherboard - if you see a small button, press it.

    3. Try inserting the install CD and do (Try) a system re-install.
  5. Moderator emeritus


    Jun 15, 2000
    Restart and this time hold down the command (⌘) and V buttons at the same time immediately after the startup chime. That will start in verbose mode where you'll see text of what it's doing instead of the Apple logo and spinner. See where it hangs for a while and write down any possible error/warning messages that show at the bottom, and post what you find.

    Edit: merged with your other thread. Please only post one thread per topic.
  6. macrumors newbie

    Feb 15, 2012
    Hi Kainjo, I have the same problem

    Thing I got (using your helpful tips) was this:
    dyld: library not loaded: /system/library/frameworks/coreservices.framework/versions/A/frameworks/metadata.framework/versions/A/metadata

    Referenced from: /system/library/frameworks/coreservices.framework/version/A/coreservices

    Reason: image not found 1 2
    The system bootstrapper has crashed: trace/BPT trap: 5

    Any ideas?
  7. macrumors 6502a


    Jul 23, 2006
    In your case, I would probably boot off an OS disk, depending on which one you have (OS 10.3, .4 or .5) and run the disk utility included on the startup media. Once running, choose "Repair Disk" to get the drive booting once more :)
  8. macrumors newbie

    Feb 15, 2012
    Hi supercompu2

    I am using 10.7.3 and I did not get a disc. This was purchased from App Store.
    Any ideas how to get it fixed or should I go to apple store and try that way?

    Thank you for you professionally advise.
  9. macrumors newbie

    Feb 13, 2012
    powerbook g4 on grey screen


    I have had issues also with my powerbook g4 1 ghz machine.

    Mine was in fact that the operating system was corrupted. So what i did, I contacted a company in San jose, CA called MacPro I think. I purchased a os x 10.5.x dvd and was able to reinstall the software. Then what i did, i ran the software update under the apple menu but i didnt download from there. Instead i went to the apple support site and downloaded each .dmg image from their site and installed in the order that software update showed.

Share This Page