Help! Problem with Messages. One contact sends to multiple devices?

Discussion in 'OS X Mountain Lion (10.8)' started by VideoNewbie, Jul 28, 2012.

  1. macrumors 6502

    Feb 6, 2009
    my cousin and her boyfriend share an itunes account.

    they each have an iphone ,different numbers but same apple account.

    my cousin also has an ipad under the same account.

    when i try and send messages to my cousin using her email (which i thought goes directly to the ipad) it not only goes to the ipad but it goes to BOTH their phones as well.

    i thought emails are only for ipads? and phone numbers are only for iphones

    how do i set it so that messages sent to the ipad are only on the ipad? or is it just made so that any time you send a message to an email all associated idevices with the account receive the same message?
  2. macrumors 604


    Mar 26, 2008
    they need to actually log OUT of the apple id on their iPhones so only their phone number will be used

    iphone > settings > messages > log out of the apple id
  3. macrumors 68030

    Sep 21, 2011
    Solution A: your cousin's boyfriend disables iMessage completely;
    Solution B: your cousin's boyfriend removes your cousin's e-mail address from the "receive messages sent to" setting, and your cousin does the same thing from her phone if she only wants those texts to arrive to her iPad.
  4. macrumors 65816

    Dec 28, 2009
    you shouldn't share Apple IDs like that.

    Have them just share Apple IDs in the store, so they can share apps, but you can set up your phone to run a different Apple ID for iCloud and iMessages... then keep a matching one for the store for purchases.

Share This Page