help! question to advanced for Apple Support...

Discussion in 'Macintosh Computers' started by Xnet, Oct 20, 2003.

  1. Xnet macrumors member

    Jun 26, 2003
    I called Apple Support and was told that my question was too advanced for them and they could not answer it.


    Anyway my problem is that I can not access my computer remotely [from office] through the airport base station at home. When the computer is connected directly to the cable modem no problem.

    I have port mapping in the base station for set up for port 22 to go to a static IP address of the type. The computer is manually set up with the same IP address [i can surf the web no prob]. The base station is giving out address using DHCP and NAT [maybe thats the problem?]. When trying to use SSH I get connection refused. I do not have the firewall enabled.

    what gives?
  2. Bear macrumors G3

    Jul 23, 2002
    Sol III - Terra
    Re: help! question to advanced for Apple Support...

    (1) Do you have sshd enabled on the Mac?
    (2) Your Macs IP address has to be the one that the static mapping is pointing to.
    (3) You have to know what IP address your Airport Base received from the cable modem. Depending on the cable service, this address can change anywhere form once or twice a day to once every few months.
  3. Xnet thread starter macrumors member

    Jun 26, 2003
    Re: Re: help! question to advanced for Apple Support...

    1] SSH enabled via Sharing Pane
    2] Port Mapping to Macs static IP
    3] I am aware of the IP address assigned to the cable modem.

    I dont understand why I keep getting
    "port 22: connection refused"
  4. illumin8 macrumors 6502

    Apr 20, 2003
    East Coast, US
    Re: Re: Re: help! question to advanced for Apple Support...

    Have you checked to make sure your work doesn't block outbound port 22 traffic at their firewall? A lot of companies do this because they don't want employees sending corporate secrets out through the network. Other than that, it should work. You might want to check out DynDNS as well because that solves the problem of what your cable modem's IP address is if it changes dynamically.
  5. zimv20 macrumors 601


    Jul 18, 2002
    if i understand your setup correctly...

    1) target computer plugged into cable modem. you are able to ssh into the target computer from outside your house.

    2) airport router plugged into cable modem, target computer can talk to router. you are unable to ssh into the target computer from outside the house.

    is that correct?

    i'd try the following test: use setup 2), but plug the target computer into the airport router w/ an ethernet cable and see if that works.
  6. Wyrm macrumors 6502

    Jan 7, 2003
    Toekeeyoe, Japan
    DHCP is your problem - since it is NAT'd behind your Airport - unless the Airport allows you to open a port to a specific machine or create a DMZ - it doesn't know where to send a port 22 request.

    I don't have DHCP running and SSH works fine.

  7. jayb2000 macrumors 6502a


    Apr 18, 2003
    RI -> CA -> ME
    DHCP wont matter, as the computer in question is not DHCP.
    Do you have a second computer at home that you can test using the internal 10.x IP to SSH?
    If that works, then double check the port mapping for a typo.
    Next, be sure you don't have RADIUS turned on.
    Finally, would it be possible to enable HTTP on the Mac at home?
    Do the same port mapping and such, but since work won't be blocking port 80, you can be sure of the connection.

    Good Luck!
  8. Xnet thread starter macrumors member

    Jun 26, 2003
    Thanks for everyones input!


    you are correct that is exactly my problem. I will try plugging in directly to the ABS after work today. thanks

    the way I have the ABS setup is using DHCP and NAT then I have a static IP address set up in the Mac and port 22 mapped to that Mac. I dont know if DHCP and NAT is the problem or not.

    I think the problem might be how to set up static IP address using the ABS.

    unfortunately I dont have another machine here. Should an attempt to SSH into my home machine from itself via the ABS work? It works when I am connected directly to the modem.
  9. trainguy77 macrumors 68040

    Nov 13, 2003
    Are you trying to connect using FTP? If not try that! I think FTP runs on port 21. Port map to port 21, and turn on FTP in the sharing control panel.
  10. dragula53 macrumors regular

    Jun 23, 2003

    woo, this is a subject I have been waiting to come up for ages.

    I cannot get port mapping to work through airport.


    I have tried many many times and ways.

    I think your problem is identical to mine.

    I cannot receive files via msn messenger, even though I have ports 1863 and 5190 open.

    I cannot host diablo 2 games. even though I have the 6000 series of ports open

    I have tried mapping them to the ip address of my computer, and to the public port

    none of it works, but it all still works when I connect directly to the cable modem.

    I have tried setting up the airport as a bridge.. and that doesn't work either

    (not to thread hijack or anything) but I think your problem is the same as mine

Share This Page