Help! Some Macbook Pro keys not working/malfunctioning

Discussion in 'Mac Basics and Help' started by hmb05, Jan 24, 2013.

  1. macrumors newbie

    Joined:
    Jan 24, 2013
    #1
    Hi,

    I am having problems with some of my keys.. from what I can gather they are u j m ; '

    When I press these keys either nothing happens/no letters appear on screen or it spits out a couple of symbols or letters like this: "bcvxz adfgs IORTUY ˙∆˚¬" The ; key will sometimes increase/decrease the sound volume.

    Ive opened the show character viewer and it shows that no keys are jammed or anything. (I am using the Australian keyboard if that means anything but I also have the US keyboard checked.. it doesn't make a difference whether only one is checked)

    I have been using the character viewer to insert the missing keys otherwise this message would not make much sense.

    I haven't spilt anything on the keys and it just seemed to happen randomly when I started using my laptop this morning.

    Please help, as yo can iagine this is getting very annoying!

    Thanks!
     
  2. macrumors 6502a

    MatLane

    Joined:
    Sep 30, 2008
    Location:
    England, United Kingdom
    #2
    Sounds like a trip to the Apple Store or reseller is on the cards

    Sounds like its a issue with the keys response and placement inside, either that or could be a software fault

    These things happen, best to take it to Apple and ask to see what is going on. It'l all be sorted there and then

    Hope this helps

    ----------

    Infact you could try a reformat, if you have a time machine backup or backup of everything....see if that works

    ----------


    OR try creating another account within accounts / or log into the guest account and see if it does it under them
     
  3. thread starter macrumors newbie

    Joined:
    Jan 24, 2013
    #3
    Unfortunately I don't have time machine or a way to backup everything at this stage.

    I just tried the guest account and had the same issues so I think a trip to Apple is in order!

    Thanks for your help!
     
  4. macrumors newbie

    Joined:
    Jun 18, 2013
    #4
    Did you figure it out?

    Did you figure it out? I am having the exact same issues. Same strange outputs. Plus, sometimes closes windows and other weird stuff.:mad:
     
  5. macrumors member

    Joined:
    Oct 16, 2012
    #5
    I'd love to renew that question as I have the same problem now. And with exactly the same keys malfunctioning... 7 ujm ;'
     
  6. macrumors newbie

    Joined:
    Nov 17, 2014
    #6
    WHAT? me too!

    having issues with my 2014 macbooc pro

    keys 789, uio, jkl, m<> dont work.

    seems its a block of keys for me .
     

Share This Page