Help! Thunderbolt to Ethernet adapter causes computer to freeze!

Discussion in 'MacBook Air' started by Saturn1217, Jan 21, 2013.

  1. macrumors 6502a

    Apr 28, 2008
    Just wanted to know if anyone else is experiencing this problem or might have any ideas on how to fix it.

    I have a brand new 2012 13" Macbook Air. This computer is great except for one thing.

    Waking from sleep in general is a bit unreliable.

    I've noticed that a lot of the unreliability is associated with my thunderbolt to ethernet adapter which I use while I am at work.

    Twice now I have plugged my macbook air into power opened it and wakened it from sleep. And then plugged in the thunderbolt to ethernet adapter (with ethernet cord attached). And then the computer completely freezes. Unresponsive. I can't put it back to sleep. Unplugging the adapter doesn't do anything. The only thing I can do is turn the computer off by holding the power button. Strangely it doesn't happen every time and after a restart I am able to get my MBA working with ethernet.

    This is a big problem as I need ethernet 100% of the time at work.

    I bought the thunderbolt to ethernet adapter from apple btw.

    I will of course call Apple and see what they say but I just wanted to see if anyone here had any ideas for a solution. I've already reset SMC twice.
  2. macrumors G4

    Oct 23, 2010
    Make sure you have installed all the software updates. Apple released a few updates for Thunderbolt and a new firmware since the Air was first released. If it is brand new, it is possible that these haven't been installed.
  3. thread starter macrumors 6502a

    Apr 28, 2008
    Update: applied a the latest firmware update which does seem to deal with thunderbolt issues. Hopefully this fixes things for good (because it is getting really annoying)

    Will update if my problems are resolved and thanks for the tip.
  4. macrumors 65816


    Sep 5, 2009
    I agree with KPOM. Install the updates. On my 2012 Air, my thunderbolt ethernet adapter works great. Maybe nothing, before I connect via ethernet, I turn off wi-fi.
  5. thread starter macrumors 6502a

    Apr 28, 2008
    So I installed all the updates and I thought things were fixed but then it just happened again today...:(

    I do notice that sometimes my laptop is trying to connect to my work's wifi (which requires you to sign in) and that this might be an issue. I will try turning off wifi before I connect ethernet but I do hope I can figure out a real solution soon. I switch between wifi at home and ethernet at work on a daily basis so remembering to turn off wifi isn't exactly the ease of use I'm used to working with macs.

    But thank you for the suggestion. Still worth a try.

    I think eventually (when I am not so busy) I will try reinstalling my OS from scratch. I just migrated over from my old computer and many things haven't been as smooth as they were on my 2009 MBP (not in term of speed but rather predictability)
  6. macrumors regular

    Jul 2, 2012
    The Netherlands

    The problem you describe i have it also, in the 6 months i have the MBA now it happened only 3 times so i'm not to worried, but still it is kinda weird. Also i have applied every possible updates.
  7. thread starter macrumors 6502a

    Apr 28, 2008
    Any updates on this?

    It is still happening to me. I am going to try the latest thunderbolt firmware update but I'm not holding my breath. Right now I just avoid the issue by never pluggin in my TB/EN adapter while my MBA's screen is open. But sometimes I forget and then BAM! all my work lost...

    It really sucks...
  8. macrumors newbie

    Feb 18, 2013
    Network settings

    Take a look on your System Preferences > Network and move your Thunderbolt Ethernet connection to first place. Then your Air will connect to Thunderbolt before WIFI.
    Hope this is helpful.:)
  9. thread starter macrumors 6502a

    Apr 28, 2008
    It already is in first place but thanks!
  10. macrumors member

    Aug 20, 2012
    same issue here on 2 rmpb. both freeze about half the time when i insert the ethernet adapter.
    anyone got more infos? only things i can provide is from syslog f.e.:
    Jun 19 14:04:46 localhost kernel[0]: AppleThunderboltNHIType2::setupPowerSavings - GPE based runtime power management
    Jun 19 14:04:46 localhost kernel[0]: AppleThunderboltNHIType2::start - type 2 sleep enabled
    Jun 19 14:04:46 localhost kernel[0]: AppleThunderboltNHIType2::start - SXFP method found
  11. macrumors newbie

    Aug 13, 2013
    Same exact issue, I have all updates, firmware is up to date.
    Macbook Pro Retina Late 2012 - i5 CPU - 8GB RAM - SSD on OS X 10.8.4
    Can't seem to find any resolution to this issue.. very frustrating.
  12. macrumors 6502a

    Jun 19, 2007
    Columbus, OH
    Did anyone report a bug for this? Make any headway?

    I experience it frequently, too, on a Retina 15-inch Early 2013 MBP.

    It seems like it happens most frequently when using the TB port nearest the magsafe connector. The one next to USB hasn't (yet) displayed the same behavior.
  13. macrumors 601

    Aug 27, 2012
    Well then that points to an iffy TB port doesn't it. If already out of warranty, I would attempt to clean that port, that's all I got.
  14. macrumors 6502a

    Jun 19, 2007
    Columbus, OH
    Interestingly, this is the second logic board that exhibits the same issue. Previous board was replaced because the graphics chip was flakey.
  15. macrumors 6502


    Aug 25, 2013
    What about you try and get the (old) USB based ethernet adapter? Sure, it's 100 Mbit max, but for me, that's enough. I got that version because I use the thunderbolt port for an external monitor.
  16. macrumors 6502a

    Jun 19, 2007
    Columbus, OH
    Good idea, but I'm already pushing gigabit to the max. The files I work with are tens of gigabytes in size. Unless there is a USB 3 gigabit adapter?
  17. macrumors 6502


    Aug 25, 2013
    Yeah, they exist. Google for it. One of my first hits is this one:

    Of course, they all require 3rd party drivers, as far as I can tell, so better be careful they are guaranteed to work with Mavericks...

Share This Page