Help! TiBook screen colors all funny

Discussion in 'PowerPC Macs' started by thumb, Feb 16, 2007.

  1. thumb macrumors 6502

    May 8, 2005
    Hi All,

    My tibook .867Ghz was working fine this morning, but now when I restarted it this afternoon, the colors are all off (lots of green and rapidly vibrating pixels in background). The computer works, I can run programs and so forth. There are no changes to the displays settings, still 1280x854 and colors "millions". When I switch to thousand or 256 colors there is no significant change.

    Any and all suggestions greatly appreciated!


  2. thumb thread starter macrumors 6502

    May 8, 2005
    I have subsequently run the apple hardware test, with no problems identified. I have also hooked it up to an external monitor, which displays everything perfectly normally, even when mirroring.
  3. thumb thread starter macrumors 6502

    May 8, 2005
    any ideas, anyone? i could really use some help since apple service hung up on me!
  4. Allotriophagy macrumors 6502a

    Sep 5, 2006
    I bought a TiBook on eBay a while ago which displayed this problem - it had been damaged in transit. Sometimes it would boot up and show only 32mb of VRAM, in which case it would display fine. Mostly it would boot up and show the full 64mb, in which case it would exhibit the same problem as yours.

    However, I did not test it with an external monitor. If yours works fine that way, then it could be something wrong with the connection between the logic board and the LCD. Might be easily sorted if you are brave.
  5. whateverandever macrumors 6502a

    Nov 8, 2006
    I don't know much about TiBooks, but with our MBP color issues like that the solution has been to reset the PRAM, NVRAM, etc. I'm not sure if you can do that on TiBooks, but try it out.

Share This Page