Help: Tiger writes to log on every key press

Discussion in 'macOS' started by Helmut Kool, May 29, 2005.

  1. Helmut Kool macrumors member

    Joined:
    Mar 8, 2003
    #1
    I just noticed that every time I press a key, the hard disk is accessed. I got worried that there might be a key logger and did some magical Terminal commands and found out that the file that was accessed is /private/var/log/windowserver.log. On every key press there appears a line like this:

    May 30 00:20:03 [2125] kCGErrorNoneAvailable: CGXKeyEventTranslate: key translation failure

    Does anybody else get this? I have a Finnish keyboard and keymap on a Powerbook running Mac OS 10.4.1.

    A Google search led to this:

    http://macslash.org/comments.pl?sid=5385&cid=93490

    That person also uses the Finnish keymap. I tried to change it temporarily to US keymap but that didn't help.
     
  2. Pandaa macrumors newbie

    Joined:
    Mar 31, 2002
    Location:
    sweden
    #2
  3. Helmut Kool thread starter macrumors member

    Joined:
    Mar 8, 2003
    #3
    Yes, I sent a bug report. They didn't fix it in 10.4.2. :-(

    A partial workaround is to make windowserver.log a symbolic link to /dev/null. That way the hard disk will stay quiet, but it doesn't really stop the error from happening. And you won't get any other (possibly useful) error messages to that log file either.
     
  4. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #4
    Didn't know about that one. Just used it to report a localisation bug which has existed since at least OS 10.2.4, which I've reported about 10 times already through the "normal" system :rolleyes: (they never bothered to fix it, despite it being ridiculously simple to fix).
     
  5. Helmut Kool thread starter macrumors member

    Joined:
    Mar 8, 2003
    #5
    That was new to me also. I reported the bug using the regular feedback form. Maybe this bug should be reported also to the ADC bug reporting thingy in case they take those reports more seriously.
     
  6. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #6
    The ADC reporter asks for a lot more detail, and also includes a tracking feature :)
     
  7. andysmith macrumors 6502

    Joined:
    Sep 24, 2004
    Location:
    West Mids, UK
    #7
    Ahh that's what this problem is - I've been having it too.
    I have a PowerBook 15" with a UK keyboard layout.
     
  8. Linkjeniero macrumors 6502

    Joined:
    Jan 6, 2005
    #8
    The cheap and dirty fix: If you don't mind losing that log, you could just do this (as root):
    cd /private/var/log/
    rm windowserver.log
    ln -s /dev/null windowserver.log
     
  9. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #9
    Solution (presented in itavisen (Norwegian) today):

    * Logg in as root (enable root user in Netinfo Manager: Security -> Enable root user (you might have to authenticate first)).

    * Set U.S. keyboard as the only Input type in System Preferences -> International -> Input Menu

    * Log out from root (and disable in Netinfo Manager if you don't want root user enabled).

    Instantly my /var/log/windowserver.log reported "Oct 19 13:24:43 [70] CGXRestartSessionWorkspace: session workspace exited for session 258 ( off console , defunct)" and stopped logging every event. :)
     
  10. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #10
    Just installed 10.4.3, reverted root Input type back to Norwegian, and no logging activity in my regular account.

    Problem solved permanently... :)
     
  11. Helmut Kool thread starter macrumors member

    Joined:
    Mar 8, 2003
    #11
    Yeah, that did the trick. I was pissed off to find out that 10.4.3 didn't fix this and started searching for a solution again. I found it on another Web forum and came back here to report it but I was too late. :)

    BTW, I noticed also that logging in as root makes it possible to enable SSH and FTP sharing, which for some reason doesn't work for me otherwise.
     

Share This Page