Help with Apache web server...

Discussion in 'Mac Basics and Help' started by Sapphyre, Mar 2, 2006.

  1. Sapphyre macrumors newbie

    Joined:
    Nov 24, 2005
    Location:
    Ontario, Canada
    #1
    I'm trying to use my computer as a web server for a few basic pages just for use by members of my family, but still can't seem to get the pages to show up for anybody who is not on my LAN. I've set the router to forward all requests for port 80 to my internal IP and set a firewall entry that is telling me that all TCP network traffic on port 80 is being let through... but I'm obviously forgetting something, because I can only access the pages from my computer or another computer on my network. I'd appreciate it if anyone could let me know what it is I'm neglecting to do... thanks :)
     
  2. edesignuk Moderator emeritus

    edesignuk

    Joined:
    Mar 25, 2002
    Location:
    London, England
    #2
    What address are you sending out to family members outside of your network?
     
  3. Sapphyre thread starter macrumors newbie

    Joined:
    Nov 24, 2005
    Location:
    Ontario, Canada
    #3
    Just the IP address... I would eventually like to set it up with my domain name, but I was just trying to get it working first.

    http://207.35.41.129/
     
  4. edesignuk Moderator emeritus

    edesignuk

    Joined:
    Mar 25, 2002
    Location:
    London, England
    #4
    When you say you've opened a port on your firewall, where do you mean? In OS X or on the router (if it has a hardware firewall?).

    I can ping that IP, but cannot access your site either.
     
  5. ScottB macrumors regular

    ScottB

    Joined:
    Jul 13, 2005
    Location:
    Britain
    #5
    It seems obvious but have you enabled the web server feature in system preferences?
    Edit: Oops never mind. :eek:
     
  6. trainguy77 macrumors 68040

    Joined:
    Nov 13, 2003
    #6
    I would read your ISP's AUP sometimes they don't want you to host your own servers. And sometimes they even block port 80. I did a port scan of the IP and 80 is not "open" that may mean that they block it. So the best way to check would be open a random port like 523 on the external side. And if you can have your router send to 80 on the lan. So then you would connect like this:
    http://207.35.41.129:523/

    EDIT: I am running a full port scan so far you only have 1 port open that i can find. I will report back when more are done.
     
  7. trainguy77 macrumors 68040

    Joined:
    Nov 13, 2003
    #7
    Well, the port scan is taking a long time. However there is ALOT of ports open. Port 80 is not one of them. Is this your IP? Do you have lots of ports forwarded? Maybe your ISP has a proxy of some sort. Or a NAT system?
     
  8. frankblundt macrumors 65816

    frankblundt

    Joined:
    Sep 19, 2005
    Location:
    South of the border
    #8
    what addresses is Apache set up to receive? you may need a virtual host alias for 207.35.41.129 as well as your local IP (or just *). Your router may be passing the requests straight thru so that Apache is receiving requests for http://207.35.41.129/ but has no host setting that relates to that domain, so rejects it.
     
  9. billraff macrumors newbie

    Joined:
    Jan 14, 2006
    #9
    typically, http will respond to any request it receives unless explicitly told not to. Telnet to that ip on port 80 fails for me so you're still blocked. Probably at your router.
     
  10. Ticout macrumors newbie

    Joined:
    Mar 13, 2006
    #10
    Help with Apache

    Is their a good site to explain how to use Apache and can we use Apache and iWeb instead of using .Mac?
     
  11. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
    #11
    http://httpd.apache.org/
     
  12. superwoman macrumors regular

    Joined:
    Apr 25, 2005
    Location:
    Monterey,CA
    #12
    The fact that machines on your own LAN can access your web page indicates that your apache web server is working correctly.

    Most likely your upstream ISP is blocking incoming port 80. Try editing your /etc/httpd/httpd.conf file to set up your web server on a different port (I believe it's the Listen directive). To be safe, use some number larger than 1024, say 8000, and restart your httpd process. Then configure your router to forward that port instead. If this works, then your ISP is blocking incoming port 80.
     

Share This Page