Help with ext Sony CDRW!

Discussion in 'Mac Help/Tips' started by madforrit, Jul 23, 2002.

  1. madforrit macrumors regular

    Joined:
    Jul 23, 2002
    Location:
    Berkeley, CA
    #1
    First off, hey everyone....
    I've been frequenting MacRumors for about two years now but this is my first post. I need your help!
    I've got a G4 450 and a Sony Spressa ext. CDRW. For some reason, I can't get OSX to recognize the burner....itunes, disc burner, toast, nothing. If I boot in 9, it's there. It doesn't show up in classic. I have installed the disc burning update also. The system profiler DOES recognize the burner (it claims the model to be CRX120E), but says that the firmware and driver are "unavailable." Apple claims this burner to be compatible on the itunes compat. page. And the Sony website appears to have no Mac drivers for any of its burners. So any help/ideas would be much appreciated. Thanks!
     
  2. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #2
    I have a firewire Sony Spressa CRX 145E, it works fine with the built-in OS X drivers - with a Sawtooth G4 400.

    I have not tried lately to see if it is recognized when left on during a reboot under 10.1.5, but on some of the older OS X versions it had problems being recognized if left on during reboot. But this was easily remedied by just turning it off and and back on.

    Even shows up under classic's Apple Sys Profiler when there is a CD in the drive, not as a firewire device, but under the Classic Mac OS Compatibility Environment.
     
  3. GeeYouEye macrumors 68000

    GeeYouEye

    Joined:
    Dec 9, 2001
    Location:
    State of Denial
    #3
    It's USB, isn't it.

    Lemme guess... it's the USB version of the drive. I had the exact same problem. The solution is to buy a FireWire enclosure and put the drive in there. After that it will work.

    If I'm wrong about it being USB, well, its a defective burner then.
     
  4. madforrit thread starter macrumors regular

    Joined:
    Jul 23, 2002
    Location:
    Berkeley, CA
    #4
    thanks

    Thanks for the info G-
    You're absolutely right...USB. If I have to spend money on a firewire case to fix it, I may as well wait til I get a new G4 (hopefully very soon, depending when steve and co. decide to release and ship). I was hoping there'd be a software fix, but in the meantime, I will just have to burn in OS9.
     
  5. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #5
  6. GeeYouEye macrumors 68000

    GeeYouEye

    Joined:
    Dec 9, 2001
    Location:
    State of Denial
    #6
    One other option

    Just thought of one other thing you can try. How badly do you need the internal CD (DVD?) drive in the G4? If not too bad, you can swap those drives instead, and there's a chance that the old drive will work in the USB enclosure. I just suggested the other way first because I didn't have a PM to do it on, just an iBook
     
  7. madforrit thread starter macrumors regular

    Joined:
    Jul 23, 2002
    Location:
    Berkeley, CA
    #7
    hmm...

    Again, thanks for the help Gee and sunbaked. I was checking out the xlr8 forums and looks like nobody with my drive and G4 (AGP) has got the thing to work. The drive swapping might work...I'll be sure to try it when I'm feeling a little adventurous.
     
  8. GeeYouEye macrumors 68000

    GeeYouEye

    Joined:
    Dec 9, 2001
    Location:
    State of Denial
    #8
    Re: hmm...

    It's not unique to your machine; the problem affects all OS X machines, not just the G4.
     

Share This Page