Help with ginormous Time Machine Backups

Discussion in 'Mac OS X Lion (10.7)' started by thaflash, Dec 22, 2011.

  1. thaflash, Dec 22, 2011
    Last edited: Dec 22, 2011

    macrumors newbie

    Joined:
    Dec 22, 2011
    #1
    So it seems like this is pretty common, and I've spent the last few weeks looking for a fix to no avail.

    Currently, I average 32GB per Time Machine backup. By the time one finishes, it starts the next one, which effectively makes my MBPro as useful as my 5 year old MB.

    I have excluded my downloads folder, parallels VM folder and external HDD's from the backups but have not had any success. In fact, after I excluded the 25GB parallels VM, my backup went up from 27GB to 37GB, this after a 32GB backup 1 hour ago.

    I've searched from programs to monitor the changes but haven't found one that works in 64bit Lion.

    Any ideas?

    Update: Just to confirm, my last backup was 37GB, before that 32GB and just now it tried to do another 37GB backup. I didn't have any time to do anything other than browse the web between backups. I would even deal with this if I could force Time Machine to only do 1 backup a day.
     
  2. macrumors 6502a

    johnhurley

    Joined:
    Aug 29, 2011
    #2
    How about going with a direct attached external drive ... should not take too long to backup 32 gb even using usb 2.0?

    How about turning off ( disabling ) local backups and just switch on and off ( again ) time machine backups when you want to get one?

    If you take control and turn time machine backups off then you can get as many of them per day ( if any ) as you want.

    Right click the time machine icon in the top tray ( right side ) and select Open Time Machine preferences ... you get a windows with a slider ( Time Machine Off ON ) and a select disk on the right side along with an options choice.
     
  3. macrumors 6502

    prisstratton

    Joined:
    Dec 20, 2011
    Location:
    Winnipeg
    #3
  4. macrumors 68030

    Joined:
    Oct 19, 2011
    Location:
    Switzerland
    #4
    To make things clear:

    Are you backing up to an external disc?
    Are you sure that you properly excluded all VM images?
    Is the backup disc full?
    Does the backup finish, or does it stop and restart after a while?
     
  5. thread starter macrumors newbie

    Joined:
    Dec 22, 2011
    #5
    I am backing up to an external usb 2.0 1TB drive. It was connected to a hub, but today I connected it directly. It started a backup at 2:36pm and finished at 3:22pm.

    I have checked to make sure I am disabling the correct VM folder, I double checked through the Parallels forums (and confirmed that I am excluding a 25GB VM file). In fact, I stopped a 27GB backup to disable that folder and then the backup shot up to 37GB. That was the backup that finished at 3:22pm and the following backup at 3:36pm was 37GB; I didn't even have enough time to move around 37GB worth of data.

    I don't see an option to disable local backups. I see the following checkboxes:
    Backup while on battery power (checked)
    Notify when old documents are deleted (unchecked)
    Lock documents [2 weeks] after last changed (just changed this to 1 day, 2 or 3 would be nice).

    The backup disk is not yet full (under 100GB available on a 1TB HDD, remember this is only from the beginning of December). However under Snow Leopard, it took 1 year to fill up a 320GB disk with backups (my computer HDD is 320GB). My average SL backups were around 20-100MB and only shot up if I downloaded a large file.

    The backups do finish.

    I made a genius bar appointment for tomorrow morning, not that I have any faith in that but this is seriously affecting my work. I would hate to drop back to Snow Leopard, it would take days to find and re-install all my data, but with iCloud Calendars not syncing with my iPhone and this Time Machine fiasco it feels like I took a huge step back in efficiency. My spare time used to be spent on the phone with MS CS trying to find out why my Windows 7 keeps de-certifying; but this is worse, I expect that kind of behavior with MS. This is the first time I have had a serious problem with a Mac.

    Edit: Regarding turning off TM. I can't remember to floss every day, there's no way I can remember to turn on TM every day and then back off. Also, if I have to do manual backups, there must be a better program than TM no?

    And a TM scheduler is a good idea, I'll look into them regardless.
     
  6. macrumors member

    Joined:
    Jul 21, 2011
    Location:
    New York suburb
    #6
    37g is not ginormous for TM. There is no reason it ought to be constantly running. If you have a vm running the smallest change could cause the whole vm file to be written to TM, and any vm should be excluded, so I would check tht again and make sure. You are writing TM to an external disk, aren't you? If not, you should. If your disk fails TM will be of no use. Writing a local file should be the exception - you re on the road without the external drive. If you have excluded the vms properly, excluded the external disks, and are in fact writing to an external disk, the only thing I can think of is you have a bad disk or bad connection that is making things painfully slow.
     
  7. macrumors 68030

    benthewraith

    Joined:
    May 27, 2006
    Location:
    Miami, FL
    #7
    In Terminal:
    Code:
    sudo tmutil disablelocal
    Your password won't show up at all, no asterisks or nothing, just type it and press enter.
     
  8. thread starter macrumors newbie

    Joined:
    Dec 22, 2011
    #8
    I don't see how 37GB isn't a huge backup for TM every hour, it's on the larger side of everything I have read on the matter; regardless, going from under 1GB to over 30GB is a pretty ridiculous change. Yes, I am backing up to an external disk. And I only run my VM once or twice a month so even if I didn't exclude it properly (which I did) it shouldn't be such a large backup every hour.


    What will disabling local backups do? Local snapshots doesn't seem like a bad thing, will it make up 30GB per hour? When looking at my system info, only 300+MB are taken up by "backups".
     
  9. macrumors 68030

    benthewraith

    Joined:
    May 27, 2006
    Location:
    Miami, FL
    #9
    See if the solution(s) this individual found will work for you:

    http://forums.macrumors.com/showthread.php?t=459451
     
  10. thread starter macrumors newbie

    Joined:
    Dec 22, 2011
    #10
    Thanks for the link, I'm going to take it one step further and securely erase the disk and start the Time Machine from scratch. I only have 1 month of backups on there and recently backed up my files manually to a second disk so hopefully nothing goes stupid.
     
  11. macrumors 68030

    Joined:
    Oct 19, 2011
    Location:
    Switzerland
    #11
    I was about to suggest this. Something is weird.

    Of course, it could be a problem with some software that renews the timestamps on some files regularly. Maybe something that doesn't work properly with Lion. In that case Time Machine would just be doing it's normal job.

    I don't know if there is a way to find out which files were updated most recently.
     
  12. thread starter macrumors newbie

    Joined:
    Dec 22, 2011
    #12
    Well, it seems to be working for now. My last backup was 3.4MB and all went well so nothing lost. I wish I had a BR burner (or at least cheap, high volume media) so I could keep refreshing this and not lose my backups; but for now I could probably live with this and just copy 1 or 2 of the backups on a separate drive every once in a while.

    Thanks guys.
     

Share This Page