help with logitech x-230 speakers...

Discussion in 'Mac Accessories' started by simonscg, Nov 12, 2005.

  1. simonscg macrumors newbie

    Joined:
    Nov 12, 2005
    #1
    ok..so i've had these speakers for a while now and i am past my warranty, and all of a sudden they decide that they just want to stop working.....
    so i decided that since i know a bit about electronics that i would open it up and see why they stopped working. i unscrewed the back panel, only to find that it will only open up about an inch, and then the whole back panel plate thing won't go any farther. i was able to peek in right there and with a flashlight was able to see that there is one wire loose, but there is still something else holding the panel from coming all the way out.
    does anyone know how to properly open this thing up!!??? i think that there is one more wire holding it back. should i just break this wire too and then splice in some new wire to connect it back again?

    if anyone has opened up one of these and has some information regarding my problem, i would really appreciate it.

    these speakers are so awesome, and i really dont want to have to throw them away. :(

    thanx
    chris
     
  2. simonscg thread starter macrumors newbie

    Joined:
    Nov 12, 2005
    #2
    haha...i fixed my speakers!! so no i dont need help anymore. i actually wound up breaking all the wires i had to to open it up, and then just basically put it back together in an easier way and they work fine now! yeahhh!
     
  3. mskoronski macrumors newbie

    Joined:
    Jun 20, 2010
    #3
    @simonscg

    can you please give me more of a detailed explantion on how you fixed your speakers
     

Share This Page