help with mac os x server

Discussion in 'Mac OS X Server, Xserve, and Networking' started by twoodcc, Mar 11, 2007.

  1. macrumors P6

    twoodcc

    Joined:
    Feb 3, 2005
    Location:
    Right side of wrong
    #1
    ok, i'm new to OS X server, and i'm having a hard time with it. i'm trying to use Open Directory, but how do i get a client computer to be able to log in to the server?

    i have setup Directory Access correctly, i think, on the client machine. but how do i get it to look for the server at the login screen?
     
  2. Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    Whakatane, New Zealand
    #2
    You should have an Other option on the login screen. If not, check your Directory Access settings again.
     
  3. thread starter macrumors P6

    twoodcc

    Joined:
    Feb 3, 2005
    Location:
    Right side of wrong
    #3
    is there a certain Directory Access setting that i'm missing? i have the client binded to the server (i think), and i have everything set right (i think). i used a turtorial to set it up, and searched apple documents online as well
     
  4. Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    Whakatane, New Zealand
    #4
    I've only done it with AD, so I'm not certain of the details with OD. However, I believe that you want to use LDAP and add the OD server in there (click New and add it).
     
  5. thread starter macrumors P6

    twoodcc

    Joined:
    Feb 3, 2005
    Location:
    Right side of wrong
    #5
    thanks. yes, i have done that. do i have to use DHCP service with it for it to work?
     
  6. thread starter macrumors P6

    twoodcc

    Joined:
    Feb 3, 2005
    Location:
    Right side of wrong
    #6
    surely someone around here has used mac os x server? please help me out if you can
     
  7. thread starter macrumors P6

    twoodcc

    Joined:
    Feb 3, 2005
    Location:
    Right side of wrong
    #7
    well, i got to login my server one time, and after updating to 10.4.9 i can't login anymore!

    i found this error in my LDAP log:

    slapd[12622]: SASL [conn=53] Failure: no user in database\n

    what does that mean?
     
  8. thread starter macrumors P6

    twoodcc

    Joined:
    Feb 3, 2005
    Location:
    Right side of wrong
    #8
    surely someone around here has used mac os x server?
     
  9. macrumors 604

    MacsRgr8

    Joined:
    Sep 8, 2002
    Location:
    The Netherlands
    #9
    Waitup....

    for Open Directory to work this must be the working order:

    - Setup Mac OS X Server preferably on a network with a DNS on which a DNS entry has been made for your Mac OS X Server.
    - Setup the Mac OS X Server as a Open Directory Master (choose a Direcory Administrator shortname, default = diradmin, and password). You'll notice the Kerberos realm to be akin the DNS entry of you Mac OS X Server
    - Create Users in the Open Directory: First Open Workgroup Manager, click on "authenticate", choose for LDAP v3, 127.0.0.1, and enter the diradmin name created above, then create users

    - Go to your client Mac. Ideally this Mac shares the same DNS as the server.
    - Goto Directory Access, and double click LDAP v3
    - Click on "new", and enter the DNS name of your Mac OS X Server / OD Master (can do with IP address aswell)
    - It should confirm the OD settings.
    - Make sure that in System Prefs, Accounts, Login Options, the "Automatically Login as.." is unchecked.
    - Reboot the client Mac, and login as OD User.
     

Share This Page