help with proxy settings

Discussion in 'Mac Apps and Mac App Store' started by jermsmingy, Aug 25, 2004.

  1. jermsmingy macrumors regular

    Joined:
    Feb 25, 2002
    Location:
    Houston
    #1
    Okay guys,

    My sister left for college and we bought her a brand new 15 inch powerbook, she gets there and the college has a web proxy. The install disk is pc only of course :mad:, so we call to get the proper settings, and of course no one in the IT department has an clue about a mac :mad:. Well, some guy comes by and sets up the proxy using internet explorer, so now the only application that can access the internet is internet explorer, not ichat or safari or mail. So I tell my sister to enter all the information in the proxy settings in system preferences. I've tried every proxy setting except FTP proxy and the automatic proxy configuration, and it will not work. I've been through it at least 30 to 40 times and I don't know what else to do. So I guess my question is, Am I doing something wrong? Could it be a problem with their proxy and if so, what could or would the problem be?

    I have the ip address for the proxy, I have the port number, and it requires a user name and password. We have entered all of that info and still no luck. Thank you for your time.
     
  2. saabmp3 macrumors 6502a

    Joined:
    Jul 22, 2002
    Location:
    Tacoma, WA
    #2
    Are you checking the check box to "use a proxy for web connections"? I did this the first time and after 5 minutes of looking felt very foolish. I know it's a dumb question, but it's worth a look.

    BEN
     
  3. jermsmingy thread starter macrumors regular

    Joined:
    Feb 25, 2002
    Location:
    Houston
    #3
    what button are you talking about I don't see that button, I have web proxy checked but I don't see the button you are talking about
     
  4. LeeTom macrumors 68000

    LeeTom

    Joined:
    May 31, 2004
    #4
    Have you tried putting it in, making sure it's checked, then closing control panel, saving configuration, and restarting?

    Also, make sure she's putting it in the Ethernet part (if that's what she's using), and not the Airport part.

    I think Web Proxy and SOCKS proxy should probably be the right one... one or the other.

    Lee Tom
     
  5. jermsmingy thread starter macrumors regular

    Joined:
    Feb 25, 2002
    Location:
    Houston
    #5
    Tried that but it doesn't work, any other ideas
     
  6. xjohn macrumors regular

    Joined:
    Jan 6, 2003
    Location:
    Beijing
    #6
    There must be a solution to this!

    I'm having the same problem. My company uses a proxy. Setting the proxy in the Network control panel allows Safari and other webkit apps to access the Internet, but mail seems oblivious.

    This must be a common problem, but I can't find an answer anywhere!

    Any ideas?
     
  7. scan300 macrumors 6502

    Joined:
    Mar 25, 2003
    Location:
    Melbourne, Australia
    #7
    Email uses a different port than http, and should be handled by a mail server on your local network. Generally http is port 80 and hopefully that is the port your admin has set for web.

    We've just started using a proxy server in our work network, windows servers with mac workstations, as we have had a long problem with authentication on previous proxy servers. Our past solution was to assign each mac with a static ip and make each one a proxy. Now we are trialling a new proxy server (I think microsoft proxy on Server 2003) and initially it didn't authenticate. (Proxy message said I didn't have permission). A tech from Microsoft came in and worked on the proxy server and now it works OK.

    The set-up was simple on the Mac. Just turn on web proxy and add your authentication details, just as you have. I assume that the network admin has confirmed your proxy and authentication details are correct.

    If the proxy server works in a windows environment, then chances are the proxy wasn't set up entirely correctly to work with other platforms. Your network admins can reference http://www.macwindows.com/ for discussions on crossplatform networking.
     
  8. Logik macrumors 6502a

    Joined:
    Apr 24, 2004
    #8
    Ok i'm going to try to document my own use with proxies here.

    I goto college at a local university and they use a proxy/cache server from Novell called BorderManager. It asks you to log in when you use Safari/Firefox but not Mail or iChat or any other applications not web browser related.

    BorderManager does NOT work with safari for some reason. It does but it doesn't. I have gotten it to work by going in and doing a bit of "hackery" to get it to work. if anyone would like me to detail how i did this then feel free to respond and i'll try to explain.

    if you are using bordermanager at that college, then your best bet is not to use safari, you'll be stuck using Firefox or another third party web browser. I can say Firefox works fine i'm using it right now with bordermanager.

    Mail, and iChat work but Shrook does not unfortunately.

    If you use bordermanager (call IT and see) and i can probably help you a little bit. but if not then i have nothing to provide :(
     
  9. xjohn macrumors regular

    Joined:
    Jan 6, 2003
    Location:
    Beijing
    #9
    Thanks for the advice. The chief challenge is that all of the IT guys only speak Chinese. My Chinese is fine, but I'm not sure how to communicate this stuff to them, because I don't necessarily understand it in English. :)
     
  10. Logik macrumors 6502a

    Joined:
    Apr 24, 2004
    #10
    For those who want to know.. i'll be posting this on my website and will reference it later on as well but this is going to be the rough draft.

    At my school we have what is called BorderManager, it's a product from Novell and is a cache server and a proxy server. On campus you are required to login to BorderManager with your school login and password to access the internet. For me this is used for wireless access using the schools wireless network.

    For whatever reason BorderManager does not work with Safari. I believe this is an OS X issue and not a real problem with BorderManager per say though I'm sure if the scripts were mucked with they could be made to work with Safari and the OS X automatic proxy setup functions in the Network sheet.

    I did however get Safari to work, not real well but it did work but randomly asked you to login over and over and over at random times.

    My college gave me an autoconfigure script that is supposed to autoconfigure everything. This script is entered into the Automatic Proxy Configuration dialog located in System Preferences->Network->Select device->Configure->Proxies panel->in the list at the bottom Automatic Proxy Configuration

    When this is done nothing works, just that simple. The script appears to be javascript and when opened in a text editor you get a bunch of if this then do this kind of stuff. It does it for each type of query on the proxy, it looks like this.

    Code:
        function FindProxyForURL(url, host)
            {
                if (!isResolvable(host))
                        return "DIRECT";
    
                if (host.search(/localhost/i) != -1)
                   return "DIRECT";
    
                if (host.search(/127.0.0.1/i) != -1)
                   return "DIRECT";
    
                if (host.search(/141.216./i) != -1)
                   return "DIRECT";
    
                if (host.search(/umflint.edu/i) != -1 )
                   return "DIRECT";
    
                if (host.search(/flint.umich.edu/i) != -1 )
                   return "DIRECT";
    
                if (host.search(/campimagination.net/i) != -1 )
                   return "DIRECT";
    
                if (host.search(/techcamp.net/i) != -1 )
                   return "DIRECT";
    
                if (host.search(/ftp.emaspro.com/i) != -1 )
                   return "DIRECT";
    
                //We only cache http, ftp and gopher
                if (url.substring(0, 5) == "http:" ||
                                url.substring(0, 4) == "ftp:"||
                                url.substring(0, 7) == "gopher:")
                        return "PROXY 141.216.78.52:8080";
    
                return "DIRECT";
    
            }
    
    if you look near the bottom you see PROXY "141.216.78.52:8080" what i did to get safari to work was place 141.216.78.52 into both http, and https that address with the port of 8080 and it did work. (note this is in the network configuration panel under proxies).

    By the way the file name is something like "cache.pac" and at my campus is located on the same server as the cache server.

    I hope this helps a bit.. if you have questions, please ask.
     

Share This Page