Help with Sound ASAP!!

Discussion in 'Mac Basics and Help' started by MacDude12, Oct 11, 2006.

  1. MacDude12 macrumors newbie

    Joined:
    Oct 11, 2006
    #1
    Hi Guys,

    After using my external speakers this weekend, my MBP has no audio through the internal speakers. And, I have a red light coming out the headphone jack. I need help ASAP.

    Thanks,
    Pete
     
  2. 2nyRiggz macrumors 603

    2nyRiggz

    Joined:
    Aug 20, 2005
    Location:
    Thank you Jah...I'm so Blessed
    #2
    What type of mac?
    Check your volume settings and if nothing happens....give the disk utility a run.

    Something to do: Plug the external speakers back in then take them out and restart:eek:


    Bless
     
  3. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #3
    In System Preferences, go to the Sound pane and in the Output section, check that Internal Speakers are selected. :)
     
  4. MacDude12 thread starter macrumors newbie

    Joined:
    Oct 11, 2006
    #4
    It is a Mac Book Pro.

    I have read on the internet this is a common occurance. I tried plugging in and unplugging and updating software. Nothing.


    Any suggestionS??

    I need help, this is driving me nuts.



    Pete
     
  5. Killyp macrumors 68040

    Killyp

    Joined:
    Jun 14, 2006
    #5
    It sounds to me like your MacBook Pro is stuck in OPTICAL OUT mode, which is for connecting to DACs or separate receivers.

    I have had a few issues like this with my MBP, basically I fixed it by inserting some headphones, switching off, switching back on again, removing the headphones and just generally mucking around with it. I think it's a glitch in the MBP's firmware...
     
  6. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #6
    Open up Audio MIDI Setup in the Utilities folder. Does it look like this?


    Picture 1.png
     

Share This Page