Help with uControl, 10.3.8, and my attempt to fix....

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by ericc22, Feb 10, 2005.

  1. ericc22 macrumors newbie

    Apr 29, 2004

    In trying to fix the problem with uControl caused by upgrading to 10.3.8, I made it worse!

    I tried the fix at After entering everything into terminal the last 2 lines produced a strange behavior:

    Eric-Cohens-Computer:~/Desktop/ucontrolfix/ucontrol1.4.4/src Eric$ make
    -bash: make: command not found
    Eric-Cohens-Computer:~/Desktop/ucontrolfix/ucontrol1.4.4/src Eric$ sudo make install


    So then I got smart. I figured I'd uninstall uControl, and then install it again, and start over again cleanly. Duh! I found that with 10.3.8 installed, I can't even install the broken uControl, so now I can't even try the fix. Doh!

    Can anyone help? Basically, I am on 10.3.8, wanting uControl, and I can't install it. Any suggestions? Do I have to just wait for the update? I fear that might be a while....

    Thanks for any and all help!

  2. SilentPanda Moderator emeritus


    Oct 8, 2002
    The Bamboo Forest
    You didn't have the Developer Tools installed it looks like... install XCode and try to recompile from the source.
  3. ericc22 thread starter macrumors newbie

    Apr 29, 2004
    Thanks! Now of course the next question, how do I do that?! And that will then let me reinstall uControl?

    I'll do some googling but if anyone has some hints, that would be great! (I am not computer knowledgeable, and am also new to Macs, so go easy on me....)

    Thank you!

  4. deebster macrumors 6502

    Oct 21, 2004
    Olde Englande
    uControl has been updated (v 1.4.6) and now works fine with 10.3.8.

Share This Page