High CPU usage on intel mini at idle

Discussion in 'Mac Pro' started by frick, Jun 14, 2006.

  1. frick macrumors member

    Joined:
    May 16, 2006
    #1
    After attaching an external firewire hard drive, I noticed that activity monitor seems to think my cpu usage is at a constant ~50% or so (under the user category), though the CPU usage of the processes listed does not add up to anywhere near this figure. CoreDuoTemp seems to agree with the figure being put out by activity monitor, but if I actually look at cpu usage in the terminal (using the command "ps -A -o pid,%cpu,command|sort -n +1") I see only a couple processes using ~1% of my CPU.

    Could this be a problem with the mini's firmware?
     
  2. blodwyn macrumors 65816

    Joined:
    Jul 28, 2004
    Location:
    Portland, Oregon
    #2
    I'm not sure about the discrepancy, but Spotlight will start to index your external hard drive when you connect it, so there will be some activity until it's finished
     
  3. frick thread starter macrumors member

    Joined:
    May 16, 2006
    #3
    I disconnected the external HD, rebooted and opened three programs (Firefox, iTunes and Mail)... the CPU usage still jumps up to ~50%. Is this normal for an intel mini, considering activity monitor is saying these applications are using 1-3% CPU each? Is it possible that some invisible process is running in the background and eating up CPU cycles (this seems unlikely since unix should be telling me everything that's running)?
     
  4. gloss macrumors 601

    gloss

    Joined:
    May 9, 2006
    Location:
    around/about
    #4
    It may well be your Mini doing some background work, such as indexing or defragging.

    Also, keep in mind that the Duo will, technically, go to 200% CPU use, so you've still got considerable overhead.

    (for the record, though, my MacBook is currently idling at about 3-6% CPU use.)
     
  5. gekko513 macrumors 603

    gekko513

    Joined:
    Oct 16, 2003
    #5
    Have you switched to looking at "All Processes" in Activity Monitor, and not just "My Processes"?
     
  6. frick thread starter macrumors member

    Joined:
    May 16, 2006
  7. imacintel macrumors 68000

    Joined:
    Mar 12, 2006
    #7
    Go to Sytem Preferences>>Sharing>>> and Find windows Sharing. Uncheck it. It uses a lot of your CPU.
     

Share This Page