Hitachi USB2 HDD woes...

Discussion in 'Macintosh Computers' started by imakoala, Oct 21, 2004.

  1. macrumors newbie

    Joined:
    Oct 21, 2004
    #1
    Hi guys,

    Im trying to get a Hitachi Travelstar USB2 (40Gb, 5400rpm) hard disk to work with my 17" PowerBook (OS X 10.3.5, 1.5Ghz, 1Gig Ram, 80Gb) without much luck. I have the PB plugged into the mains, yet with either port when you plug the device in, the device seems to make a constant "click" noise?
    I've tried the hdd on a iMac and G4 and the hdd does appear, but it appears to be read only? Therefore, causing me problems if I choose to place files onto the hdd?
    So there is actually 2 dilemmas here!

    Any help is appreciated! Desperate to get this working.
    Thanks,
    Matt.
     
  2. macrumors 6502

    davegoody

    Joined:
    Apr 9, 2003
    Location:
    Reading, Berkshire, England
    #2
    Sound's Terminal (No Pun Intended)

    If the HDD is clicking it does sound like one of two things - either the drive is suffering from Sticktion (sp ?) or the USB2 port on your PB is not supplying enough juice. If the drive is only mounting read-only on the other machine, it may be that 1) permissions are screwed or 2) the drive is in Failsafe mode. In either case, if new enough I would get it swapped out under warranty ! :mad:
     
  3. thread starter macrumors newbie

    Joined:
    Oct 21, 2004
    #3
    I was thinking about swapping it under guarantee, but a couple of friends also possess the same drive and the same occurs, so surely they can't have made that many faulty drives? They were all purchased at various times at various cities around the world! :]
     

Share This Page