Holding keys has iPhone effect

Discussion in 'Mac OS X Lion (10.7)' started by Arkanok, Jul 28, 2011.

  1. macrumors 6502a

    Arkanok

    Joined:
    Feb 13, 2007
    #1
    Ok so sometimes for whatever reason, I want to hold a key -- for example the "e" key -- to repeat that character a few times, but with Lion I can't do that!

    Now every time I hold a key, I get the iPhone effect. What I mean by that is where it shows the different characters related to that particular key rather than just repeating it.

    I can't figure out how to turn this off. I've gone into both the keyboard settings and the text and language settings but can't figure out how to turn it off. Can someone help please!

    Here's a pic of what I mean.
     

    Attached Files:

  2. macrumors member

    spincr

    Joined:
    Jan 30, 2011
    Location:
    The Netherlands
    #2
    Hm, sorry i can't help you out, but over here its still does eeeeeeeeeeeee.. nothing with special characters.
     
  3. thread starter macrumors 6502a

    Arkanok

    Joined:
    Feb 13, 2007
    #3
    So nobody else has seen this or knows how to get rid of it?
     
  4. spincr, Jul 28, 2011
    Last edited: Jul 28, 2011

    macrumors member

    spincr

    Joined:
    Jan 30, 2011
    Location:
    The Netherlands
    #4
    Well i know (because i read it somewhere) that it is supposed to do whats its doing at your side. However i haven't seen anything on disabling those features, same goes for a ridiculously worthless launchpad where not even half of the options are working (at least on my mbp mid 2010).

    So for now, unless someone has the answers i suggest you contact apple via their website.
     
  5. macrumors regular

    Joined:
    Oct 9, 2008
    #5
    Open terminal which is in the application utilities folder and trype

    defaults write -g ApplePressAndHoldEnabled -bool false

    Then restart the computer and it should be let you repeat.
     
  6. macrumors 6502a

    TheJing

    Joined:
    Jun 13, 2011
    Location:
    Somewhere in Europe
    #6
    Just type this in Terminal.

    defaults write -g ApplePressAndHoldEnabled -bool false
     
  7. macrumors regular

    Joined:
    Jul 14, 2008
    #7
    It's a system-wide "feature" of Lion -- not sure how others aren't seeing it, unless it has something to do with upgrading from previous systems.

    Anyway:

    → Open up your terminal
    → Enter the following command (no quotes): "defaults write -g ApplePressAndHoldEnabled -bool false"
    → Restart your computer.

    EDIT: see now that others beat me to it...good luck!
     
  8. macrumors 68030

    Joined:
    Jul 21, 2011
    Location:
    Los Angeles, CA
    #8
    I still want to know why you would ever need to spam a certain key? There is absolutely no purpose and I applaud apple for finally making use of a useless function!
     
  9. macrumors 6502

    Variant

    Joined:
    Oct 22, 2005
    #9
    I sorta like this features. I just wish that holding the numbers would bring up a short cut for sub and super script numbers!
     
  10. macrumors 6502a

    hollerz

    Joined:
    Sep 13, 2006
    Location:
    Durham, UK
    #10
    Agreed!

    That would be awesome! :D
     
  11. macrumors member

    Joined:
    Dec 4, 2010
    Location:
    US
    #11
    Wow, I'm glad I saw this thread! My 10.7 defaulted the the standard spam behavior (and I'm not sure why, I did a clean install), but I much prefer the new behavior. It's a feature I would never have even realized existed!

    Needless to say, I meandered on over to my terminal and activated it.
     
  12. macrumors regular

    Joined:
    Nov 6, 2009
    #12
    Indeed... If you write in a language with a lot of accents, it's a godsend :)
     

Share This Page