Hot Corners & Expose Stop Working (Until Restart)

Discussion in 'OS X Mountain Lion (10.8)' started by orvn, Aug 10, 2012.

  1. macrumors 6502

    Jan 11, 2011
    Toronto, Canada
    So ever since I got Mountain Lion, I've been having this issue.

    When I first start up my machine, my hot corners (set to exposé, show desktop and dashboard) work.

    Then, inevitably, a few hours later they just stop working.

    The F3 button on my MBP (unibody core2duo mid-'09) doesn't trigger the exposé and my four-finger trackpad swipes don't work either.

    Killing the windowserver process, logging out/in or restarting fixes the issue, but each time I fix it I know it will just occur again.

    Sometimes it occurs within an hour, sometimes it takes a day, but it happens every time.

    My hot corners + expose + trackpad gestures are all configured correctly in prefs.

  2. macrumors newbie

    Aug 11, 2012
    same same

    I got the same issue with my iMac....driving me it does not mount NTFS 3G formatted external HDD anymore.......
    start up time is is shut down time.....
    thinking about going back to Snow Leopard...was working like a fiddle with that......
  3. macrumors newbie

    Nov 6, 2006
    Screen Saver

    Taking a hint from another forum, I disabled my screensaver.

    Everything seems to be working now.

  4. thread starter macrumors 6502

    Jan 11, 2011
    Toronto, Canada
    I don't use a screensaver, interesting tip though.
  5. macrumors regular

    Dec 6, 2003
    Hot corner work around

    I have the same problem with hot corners that stop working, randomly.

    I get around this by going to system preferences and toggling hot corners to another function and back, the close Sys. Prefs. and they start working again. At least you shouldn't have to restart.
  6. macrumors member

    Nov 2, 2007
    Same problem here. Screensaver disabled, have tried changing function back and forth - but no luck. Please adress this Apple!
  7. macrumors newbie

    Feb 5, 2008
  8. macrumors 68000


    Feb 26, 2012
    Michigan/Ohio, USA
    Whenever it happens again, try opening up Terminal and type the following command:

    killall Dock
    Hit enter. That seems to be an easier fix than restarting the whole computer. At least for me anyway.
  9. macrumors 6502

    Sep 23, 2007
  10. macrumors newbie

    May 13, 2010
    Same problem here on my early 2008 Mac Pro. Killall Dock fixes the problem (temporarily for me).
  11. macrumors 6502a


    May 28, 2010
    Prince George, B.C. Canada
    Mt Lion and Snow Leopard here...

    Oddly, the first time I've run into this was today on my wife's laptop (snow leopard). She has never complained of it before and I ran SL for years on a number of different systems. Then, just a bit ago, it happened on my, fairly new, Mt. Lion based mini. So, I found this thread, and sure enough, changing prefs and then back fixed the problem (we'll see about temporarily). I'm not sure if that will fix the SL laptop or not yet. Quite odd. (And, it hasn't happened on Mt. Lion until tonight... and I've been running it for a couple months now. I'm also a HEAVY expose user, so I'd have noticed.)
  12. macrumors regular

    Mar 22, 2010
    It just works. ;)
  13. macrumors regular

    Dec 6, 2003
    Hot corner == Hot sides

    My lower-left corner is assigned to the desktop. When hot corners "break" which is usually after waking from sleep, the new hot "corner" is about 1/4 or 1/3 'up' from the lower left corner along the left edge of the screen, really weird.

    My upper right corner is assigned to Notifications, I haven't found any evidence of a new hot spot location for that corner as I did with the lower left corner.

    (FWIW, my dock is also along the left side of the screen)
  14. macrumors 6502

    Oct 12, 2005
    It's just another bug (I have that bug as well), Mountain lion is full of bugs.
  15. macrumors regular

    Dec 6, 2003
    Thanks for your depth and insight.

    I haven't had this problem since 10.8.3. Anyone have this hot corner problem since 10.8.3?
  16. macrumors newbie

    Apr 4, 2013
    I just got this problem now and I'm on 10.8.3, but
    killall Dock
    fixed it. Thanks for the tip. :)

    (I just registered to reply that I got this issue.)
  17. macrumors 68030

    Krazy Bill

    Dec 21, 2011
    Or... for the terminally challenged you can just go into system preferences, change the hot corner to something else, then back again. Hot Corners will function again.

    This happens about every other month for me. The "quirk" has been happening since Leopard.
  18. 3bs
    macrumors 603


    May 20, 2011
    Dublin, Ireland
    I started getting this problem on my Late 2013 13" rMBP. I'm not sure when it started but I'm on 10.10.3 right now. Only way to fix it is change hot corners in settings or killall dock in terminal.

    The weird thing is it happens randomly and if I ignore it, it'll fix itself and then come back again randomly. Even weirder is only top right, bottom left and bottom right corners stop. My top left corner never stops working. I tried changing the actions of the hot corners around but it was the same corner that kept working when others stopped. My dock is on the left in case that matters.

    Anyone have a permanent fix?

    PS sorry to revive a somewhat old thread.

Share This Page