How Apple will get your $129 (presumably)

Discussion in 'Mac Apps and Mac App Store' started by Beligerent, Jan 5, 2007.

  1. Beligerent macrumors regular

    Beligerent

    Joined:
    Oct 24, 2003
    Location:
    Exeter, NH
    #1
    One of the things I never liked about Safari was how its updates were tied to the Operating System updates. I never liked spending $129 to get improved browser functionality.

    As it stands right now Safari is not compatible with Google Docs & Spreadsheets. Google has said, "We're working on it" for months and months. I predict that the next update to Safari ($129 presumably) will magically fix all of this. :mad:

    I recall a similar thing happening a couple years ago. iMovie 3 was out and working fine as of its 3.03 update, Apple released a Quicktime update and this update REMOVED the ability to use iTMS purchases in iMovie projects. The only way to get the functionality back was to buy iLife 04. :mad:

    Sorry I'm ranting.
     
  2. a456 macrumors 6502a

    a456

    Joined:
    Oct 5, 2005
    #2
    Rightly so I'd say.
     
  3. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #3
    ***shrug***

    I don't use Google Docs extensively but I do occasionally use it with Safari...I haven't run into any major problems with it.
     
  4. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #4
    right now, leopard looks not attractive to me, have to wait and see all the features when it comes out. it will be cheap for me for education discount tho, but not really interested spend money on something not useful, Tiger is pretty good so far for me.
     
  5. radiantm3 macrumors 65816

    radiantm3

    Joined:
    Oct 16, 2005
    Location:
    San Jose, CA
    #5
    It seems like a bunch of developers are releasing their next version software as "Leopard Only" so there has to be some huge improvements when developers are willing to cut off a big percentage of their user base to use the latest mac os technologies. OS updates aren't all about the latest in "eye candy".
     
  6. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #6
    So just install FireFox, where's the problem. Safari is not the only browser in the world.

    B
     
  7. DavidLeblond macrumors 68020

    DavidLeblond

    Joined:
    Jan 6, 2004
    Location:
    Raleigh, NC
    #7
    If you want to use Core Animation in your product it will magically be Leopard only.

    Just like if you use Core Data in your product it is Tiger only.
     
  8. MacBoobsPro macrumors 603

    MacBoobsPro

    Joined:
    Jan 10, 2006
    #8
    For that $129 you get 18 months of free updates though. It just so happens that $129 is due soon.

    Which I am very pleased about. ;)
     
  9. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #9
    i would imagine when the softwares i need become Core Animation only, OSX 10.6 will be out for some time already..... apple's OS releasing pace is, as I see it, much faster than major softwares' developments.
     
  10. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #10
    well
    1. i doubt how many developers who has influential softwares are doing that
    2. I doubt how many of those im using

    I guess its all my personal situation, for the softwares i use, I didn't see any of them going leopard only...but yeah, if the important softwares (for me) goes that way, i would buy leopard.
     
  11. MRU macrumors demi-god

    MRU

    Joined:
    Aug 23, 2005
    Location:
    Ireland
    #11
    Apple will get my money because of the added extra to leopard regardless.
     
  12. jsw Moderator emeritus

    jsw

    Joined:
    Mar 16, 2004
    Location:
    Andover, MA
    #12
    Download the latest version of WebKit. It's essentially what the latest development version of Safari is at any given time, and in fact uses some of Safari's libraries (i.e., don't delete Safari), but often has some nice tidbits in it that aren't in the current "official" version.
     

Share This Page