How can I add my phone number to iMessage on iPad?

Discussion in 'iPad Tips, Help and Troubleshooting' started by Sirious, Feb 11, 2013.

  1. macrumors 6502a

    Sirious

    Joined:
    Jan 2, 2013
    Location:
    United Kingdom
    #1
    I have set up iMessage on my iPhone and it works perfectly. Someone sends me an iMessage to my iPhone via my email or number, I will receive it.

    But I don't seem to see an option in settings for iMessage to allow me to recieve at my number (if that makes sense).

    I want to add my number to my iPad's iMessage settings so that if someone sends me an iMessage to my number, it is sent to all my devices with the same Apple ID. Any way I could do this?
     
  2. macrumors demi-god

    Joined:
    Oct 14, 2005
    Location:
    Virginia Beach
    #2
    Assuming that you're signed into iMessage on both devices with the same Apple ID, I'd try signing out of iMessage on the iPad, waiting a sec, and then signing back in.
     
  3. thread starter macrumors 6502a

    Sirious

    Joined:
    Jan 2, 2013
    Location:
    United Kingdom
    #3
    I have tried that, but I cant see my phone number as an option to receive iMessages at on my iPad.
     
  4. macrumors 68030

    HazyCloud

    Joined:
    Jun 30, 2010
    #4
    Turn off iMessage and FaceTime on all of your iOS devices and wait a few minutes. Then turn them back on. The syncing of a phone number is done automatically since we only have the option to add another email address and not a phone number.
     
  5. thread starter macrumors 6502a

    Sirious

    Joined:
    Jan 2, 2013
    Location:
    United Kingdom
    #5
    I've solved it. I just set my phone to send/recieve at my email address. :)
    Thanks guys!
     
  6. macrumors 68030

    HazyCloud

    Joined:
    Jun 30, 2010
  7. thread starter macrumors 6502a

    Sirious

    Joined:
    Jan 2, 2013
    Location:
    United Kingdom
    #7
    Oh sweet, I just tried this and my phone number appeared on my iPad! Thank you!
     

    Attached Files:

  8. macrumors 68030

    HazyCloud

    Joined:
    Jun 30, 2010
    #8
    No problem. It's very handy being able to reply to messages sent to your iPhone on your iPad. ;)
     
  9. macrumors regular

    Joined:
    Apr 7, 2010
    Location:
    Midwest USA
    #9
    Yes. Activate the option to use the email address on the iphone. That will open up the ability to use the phone number on the ipad. It doesnt make any damn sense, but thats how they have it set up.

    e
     
  10. macrumors 6502a

    Supermallet

    Joined:
    Sep 19, 2014
    #10
    I have a slightly different question that perhaps you guys can answer. I have two Verizon sim cards and two different phone numbers. Both SIM cards were at one point in iPhones and were active on iMessage. I moved one of the SIM cards to my iPad, and wanted to use the phone number for that SIM card for iMessage with my wife, while everyone else got my iPhone number. This worked for a while, but now the phone number associated with the SIM card in the iPad has disappeared, and I can only send and receive from the iPhone number. Does anyone know any way to fix this?

    If I put the SIM card back into my spare 5c, it will recognize it as a usable number for iMessage, and it appears to stick when I put it back in my iPad, but after a few minutes the number disappears again. This is quite vexing.
     

Share This Page