How can I safely remove my Android USB cable from my Mac without doing a Force Close?

Discussion in 'Alternatives to iOS and iOS Devices' started by magentawave, Oct 9, 2012.

  1. macrumors regular

    #1
    I have a Macbook Pro and a Samsung Galaxy S2 i727 Skyrocket phone. When I plug the phone into my Mac with the USB cable I can see the disks on my Macs desktop and I can move files, etc. The problem is that the only way I can get my Android phone disks off of my Macs desktop is by doing a Force Close and it takes quite a while just to close them doing that. And this is even when I click the "Turn off the USB storage" button on my phone. I tried some Google Transfer app that I installed on my Mac and that never even saw my phone so I deleted that. I also tried a free Mount app from the Google Playstore and deleted that because it kept searching forever trying to find what I connected to without ever finding it.

    Does anyone know how I can get the Android disks to close quickly from my Macs desktop? I read somewhere that after I click the "Turn off the USB storage" button on my phone that its okay to remove the USB cable without hurting anything even though I'll get the warning message on my computer. Does anyone know if thats true?

    Thanks :)
    Steve
     
  2. macrumors 68030

    wonderspark

    #2
    I don't have an S2, but my Android phone in disk mode disappears from the Mac desktop in about one second or less. I'm on 10.6.8, so maybe you can figure out the problematic combination that is giving you trouble.
     
  3. macrumors regular

    #3
    I'm using 10.6.8 too. Thanks but I posted this issue here in the hopes that someone would know what to do. :confused:
     
  4. macrumors 68000

    paulsalter

    #4
    Not sure if I missed this in first post, for me when i connect

    right click on desktop disk, select eject
    then turn off usb mode from phone

    I think i read somewhere you shouldn't need to eject it, but i always eject any external device before removing it
     
  5. macrumors 68000

    daveathall

    #5
    My MBP doesn't recognise my S3 when it is plugged in by USB, nothing shows. Am I missing something here fellas or do I have to use Kies?
     
  6. macrumors 68000

    paulsalter

    #6
    Not sure if this is the same on the S3, under settings/developer options do you have one for USB debugging?

    this should allow it to mount as a drive
     
  7. macrumors 68030

    blackhand1001

    #7
    For devices that started with android 4.0 I believe they now use mtp, so you need the android transfer software. This is how it is on the galaxy nexus at least.
     
  8. macrumors 68000

    daveathall

    #8
    Thanks very much, I tried that but it doesn't seem to work, although my phone says connected as a USB media device, nothing shows on my MBP. My device is on Android 4.0.4 so as blackhand1001 advises, I need the Android transfer software. Thank you very much for answering though.:)

    Thank you very much for the answer.:)
     
  9. macrumors regular

    #9
    I have been trying to do that but the only way to eject the Android disks is to do a Force Eject which is slow to do. Yes, I think I read somewhere that once you turn off the USB on the phone that its okay to detach the USB cable in spite of the error warning I'll get on my Mac. Does anyone know if its true that this doesn't damage anything?




    And what is Kies supposed to do?




    Thanks but I tried that and it didn't make any difference.




    Thanks but I downloaded the Android Transfer software and it wouldn't recognize my Android so I deleted it.

    Anyone else know about this please?
     
  10. macrumors 68000

    daveathall

    #10
    http://www.samsung.com/uk/support/usefulsoftware/KIES/JSP

    I find that once I updated to Mountain Lion it never worked correctly, there is a workaround but that always seems to have an update pending for my S3, but once I try to install it, it goes through all the stages and then there is still an update pending. So I uninstalled it..
     
  11. macrumors regular

    #11
    BTW... Here is a screen capture of the error message I'm getting on my Mac when I remove the USB cable from my Android phone even though I turned the USB Storage off...
     

    Attached Files:

Share This Page