How can I select Western ISO Latin 9 encoding in Mac OS X Tiger?

Discussion in 'macOS' started by the Falcon, Aug 8, 2005.

  1. the Falcon macrumors member

    Joined:
    Jun 12, 2005
    #1
    Is there any way that I can use Western ISO Latin 9/iso-8859-15 character encoding in Mac OS X Tiger?
    I think it's weird that it only lets me choose between ISO Latin 1 and Mac OS Roman all the time.
    I can still type the € (Euro) symbol even without Latin 9, for some reason. Sometimes when I view mail or web pages, however, Euro symbols show up as question marks (?). It's annoying, especially since I live in Europe, where the Euro symbol is kind of important and used a lot (for obvious reasons).
    Thanks in advance for any help.
     
  2. Soulstorm macrumors 68000

    Soulstorm

    Joined:
    Feb 1, 2005
    #2
    In what application you want? Or you mean Tiger?
     
  3. the Falcon thread starter macrumors member

    Joined:
    Jun 12, 2005
    #3
    Well, in all applications that come with Mac OS X, I can not select ISO Latin 9/ISO-8859-15. Only ISO Latin 1 or Mac OS Roman. In Firefox, for example, I can select ISO-8859-15, but not in, for example, Mail or Safari. Not even in Dreamweaver for Mac, actually. I'm used to using ISO-8859-15 on my PC. Now I've switched to Mac, but I'd still like to use ISO Latin 9, if possible.
     
  4. HiRez macrumors 603

    HiRez

    Joined:
    Jan 6, 2004
    Location:
    Western US
    #4
    Now way that I'm aware of to add that encoding type, but have you tried poking around in the International pane of System Preferences? Maybe setting the currency to Euro or using UK monetary formats would work. :confused:
     
  5. the Falcon thread starter macrumors member

    Joined:
    Jun 12, 2005
    #5
    I have already set the currency to Euro, but that didn't help. I don't know how to change the money or number formats; that doesn't seem possible in System Preferences.
     
  6. mscnln macrumors newbie

    Joined:
    May 19, 2005
    #6
    If the website is set up correctly, it will specify its encoding and safari and firefox will display it with the specified encoding, the same is true for mail. This isn't the best solution, but the problem is really on the web server's and people with crappy mail client's side, not os x's.
     

Share This Page