How come I can't delete folders off my external hard drive?

Discussion in 'Mac Accessories' started by rockizza08, Oct 25, 2012.

  1. macrumors member

    Joined:
    Jun 26, 2010
    Location:
    Philippines
    #1
    I have a 1tb WD external hard drive, and it was working fine using it with my MacBook Pro, until a friend of mine used it to copy a movie file from that WD external hard drive, and plugged it in her Sony VAIO laptop. I copied another movie stored in a folder from her. And when I moved the folder to my "Movies" folder, it just made a copy. I tried deleting the original folder by dragging it to Thrash but it won't delete the folder. Right after I drag it into the Thrash, it says "Finder requires that you type your password". I do that, but it still doesn't delete the folder. I'm afraid this is what's gonna happen to every folder I copy. Please help me. I don't have a place to move/transfer 300GB of files, pictures, etc. Thank you so much in advance.
     
  2. macrumors 603

    Joined:
    Feb 20, 2009
    #2
    Sounds like a permissions and "file/folder ownership" problem to me.

    You might try this (NO promise that it will work, but worth a try).

    1. Connect the external drive. Close all windows (on the external) so that only the drive icon is showing.

    2. Click the external drive icon ONE time to select it, then type "Command-i" (for "get info")

    3. When the Get Info box opens, look down at the bottom of the window. Is there an "Ignore ownership on this volume" checkbox? If so, put a check into it.

    4. Enter your password when prompted.

    5. Now try to delete the problem folders/files. Any better?
     
  3. thread starter macrumors member

    Joined:
    Jun 26, 2010
    Location:
    Philippines
    #3
    No there isn't any. :| Just "You can read and write"
     
  4. macrumors 65816

    marzer

    Joined:
    Nov 14, 2009
    Location:
    Colorado
    #4
    With read and write permitted for your username, go to the little settings gear and "apply to all subfolders". That'll let you delete the folder and all its content.
     
  5. thread starter macrumors member

    Joined:
    Jun 26, 2010
    Location:
    Philippines
    #5
    Where can I find that? :s Thank you.
     
  6. macrumors 6502a

    AppleMacFinder

    Joined:
    Dec 7, 2009
    #6
    Alternative way:

    Open terminal and do a recursive chmod to change the permissions to "allow everything":

    Code:
    sudo chmod -R 777 /Volumes/[your external hard drive]
    Then, try to remove them again.
     
  7. macrumors 65816

    marzer

    Joined:
    Nov 14, 2009
    Location:
    Colorado
    #7
    The gear icon at the bottom of the "Get Info" window.
     
  8. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #8
    Right-click on the drive in Finder and "Get Info". What is the format of the drive? If it is NTFS, you'll need additional software (if you don't already have it installed) to write to an NTFS drive.

    HFS+ (Hierarchical File System, a.k.a. Mac OS Extended (Journaled) Don't use case-sensitive)

    NTFS (Windows NT File System)
    • Read/Write NTFS from native Windows.
    • Read only NTFS from native Mac OS X
      [*]To Read/Write/Format NTFS from Mac OS X, here are some alternatives:
      • For Mac OS X 10.4 or later (32 or 64-bit), install Paragon ($19.95) (Best Choice for Lion and Mountain Lion)
      • For Mac OS X 10.5 and later, including Lion, FUSE for OS X
      • For 32-bit Mac OS X, install NTFS-3G for Mac OS X (free) (does not work in 64-bit mode)
      • For 64-bit Snow Leopard, read this: MacFUSE for 64-bit Snow Leopard
      • Some have reported problems using Tuxera (approx $36), which is an enhanced version of NTFS-3G with faster performance.
      • Native NTFS support can be enabled in Snow Leopard and later versions, but is not advisable, due to instability.
    • AirPort Extreme (802.11n) and Time Capsule do not support NTFS
    • Maximum file size: 16 TB
    • Maximum volume size: 256TB
    • You can use this format if you routinely share a drive with multiple Windows systems.
     
  9. thread starter macrumors member

    Joined:
    Jun 26, 2010
    Location:
    Philippines
    #9
    How do I do this? :s Sorry.

    ----------

    I'm sorry, but I can't seem to find that. There isn't any. :|

    ----------

    My drive's format is MS-DOS (FAT32).
     
  10. macrumors 65816

    marzer

    Joined:
    Nov 14, 2009
    Location:
    Colorado
    #10
    You have to expand the "sharing &permissions" section on the "get info" window. Then you will see the little gear. Click on it and select "apply to subfolders".
     
  11. thread starter macrumors member

    Joined:
    Jun 26, 2010
    Location:
    Philippines
    #11
    It doesn't have that. :| Here's a picture of my drive's info.
    http://i48.tinypic.com/2lvob5g.png
     
  12. macrumors 65816

    marzer

    Joined:
    Nov 14, 2009
    Location:
    Colorado
    #12
    Sorry. Just saw this. No, you won't have permission options on a Fat32 partition. You may need to try a command line option as suggested previously.
     
  13. thread starter macrumors member

    Joined:
    Jun 26, 2010
    Location:
    Philippines
    #13
    Could you please help me how to do that? :s Thank you so much.
     
  14. macrumors 6502a

    AppleMacFinder

    Joined:
    Dec 7, 2009
    #14
    To find out the name of your external hard drive, you need to open Finder, then:
    1) (menubar at the top of screen) Go -> Go to folder -> "/Volumes"
    2) or Command+Shift+G -> "/Volumes"

    There are two ways to open the Terminal application:
    1) open Launchpad -> Other -> Terminal
    2) open Finder -> Utilities -> Terminal

    Command usage example: if my external hard drive is called "Storage", I need to type the following command in Terminal:

    Code:
    sudo chmod -R 777 /Volumes/Storage
    Press Enter. Then, I type my admin password and press Enter again.
    After the completion of command, permissions are set to "allow everything".
     
  15. macrumors 65816

    marzer

    Joined:
    Nov 14, 2009
    Location:
    Colorado
    #15
    I know this thread has been in play for awhile, but i'm gonna throw it out there anyway.

    Seeing how FAT32 has no inherent access control, i'm inclined to think its a realtime system discrepancy. Have you tried rebooting the system? Shut the computer down. Power off the external drive. Power both back on. Try to repeat the folder delete operation.

    ----------

    I haven't worked with a FAT partition or many years, but i do remember FAT lacks access control. Do you think chmod would actually have any affect? Do you think chmod is aware of FAT enough to simply toggle the Read bit when instucted to open up all access? Could be the OP's folder is simply showing as read-only to OS X.
     
  16. thread starter macrumors member

    Joined:
    Jun 26, 2010
    Location:
    Philippines
    #16
    http://i49.tinypic.com/674igy.png This is what happens.
    I'd type the password, but it doesn't show anything. It's just blank. :|

    ----------

    Yes I have, many times. It still doesn't delete the empty folders.
     
  17. macrumors 6502a

    AppleMacFinder

    Joined:
    Dec 7, 2009
    #17
    Terminal doesn't show the input symbols when you type a password (even at the form of *)
    so people behind you cannot count how long is your password. It is completely normal.

    It seems, the command completed successfully, please try removing folders again.
    If that does not work, you could try to remove them with terminal - more powerful than removing with Finder :

    1) Find out the path to folder you want to delete:
    Right click on this folder + Get Info. Copy the WherePath.

    2) WholePath = WherePath/FolderName

    For example, I want to remove folder with a FolderName: lolwut.
    WherePath: /Volumes/Storage/Backup/RandomThings
    WholePath: /Volumes/Storage/Backup/RandomThings/lolwut

    3) Open Terminal and type the following command:

    Code:
    sudo rm -rf [B]WholePath[/B]
    In my case:

    Code:
    sudo rm -rf /Volumes/Storage/Backup/RandomThings/lolwut
    If your WholePath contains space symbols, you need to put it in quotation marks. For example:

    Code:
    sudo rm -rf "/Volumes/Storage/Backup/Random Things/lol wut"
    This thing should work, it is more powerful than Finder.
    However, the folder will be deleted permanently - without moving to Trash.
     
  18. macrumors 6502a

    AppleMacFinder

    Joined:
    Dec 7, 2009
    #18
    rockizza08 ,

    Have you solved the problem? If yes, what was the working solution?
    Please share, so other people with the same problem could use it.
     
  19. thread starter macrumors member

    Joined:
    Jun 26, 2010
    Location:
    Philippines
    #19
    It didn't work. :|
    It said, "Operation not permitted"

    ----------

    I think it deleted all the files on my hard drive! :(

    ----------

    OMG, please help me with this. All my files are there. :'(

    ----------

    I'm literally crying right now..
     
  20. macrumors 6502a

    AppleMacFinder

    Joined:
    Dec 7, 2009
    #20
    It permits you after you type the password.

    If you specify the deletion path as the path to hard drive, for example,
    "sudo rm -rf /Volumes/Storage" - yes, it could delete all files.

    But, I really hope that you followed the instructions correctly and
    used the command in the correct way, like in my previous post.
     
  21. thread starter macrumors member

    Joined:
    Jun 26, 2010
    Location:
    Philippines
    #21
    But all the folders are still there. It's just empty. :'(
     
  22. macrumors 6502a

    AppleMacFinder

    Joined:
    Dec 7, 2009
    #22
    "sudo rm -rf" certainly could not do it such a way, no matter what path you add.
    If it deletes folder, it deletes the whole folder, and not just contents of this folder.

    I believe, something is wrong with your harddrive, and the previous inability
    to delete the folder could have been just a symptom of harddrive bad condition.

    However, it should be possible to recover the files. For now,
    don't write anything to hard drive, or it might do the things worse.

    Please tell me, what kind of filesystem your harddrive is using?
    FAT32, NTFS, HFS+, or something else?
     
  23. thread starter macrumors member

    Joined:
    Jun 26, 2010
    Location:
    Philippines
    #23
    I believe that too..
    And it's all because of that one time when I plugged it into a Sony VAIO laptop? :|
    It's MS-DOS FAT32.
     
  24. macrumors 6502a

    AppleMacFinder

    Joined:
    Dec 7, 2009
    #24
    I advice you to connect the hard drive to some Windows machine and try Recuva with a Deep Scan mode.
    This mode takes more time (several hours), but it's able to recover a lot more files.
    After Deep Scan completes, recover the files, putting them on Windows machine.

    Avoid writing to hard drive until you complete the recovery.
    Because, if you do that, some of important files that you want to recover could be overwritten.

    I like this utility - used it in the past to recover the files from my boss computer,
    with some excellent results. And also, it is completely free.

    The only problem you could encounter is that, because of corrupted file system,
    your files might not have the original filenames - so, you'll need to spend some time
    analysing the recovered files, deleting junk and renaming important files.
     
  25. thread starter macrumors member

    Joined:
    Jun 26, 2010
    Location:
    Philippines
    #25
    I'm trying this Disk Drill Data Recovery Software I found in this website.
    Been running for 12 minutes now, so I'm just waiting if something good will happen.
    Yes, I found Recuva, because I panicked and cried a lot. Only problem is it's for Windows.
    Thank you though. Will it really help me recover 250GB of files?
    Because I really can't lose all those original HQ pictures.. :'(
     

Share This Page