How do I clear Safari cache in iOS 6?

Discussion in 'iOS 6' started by PatriotInvasion, Sep 28, 2012.

  1. macrumors 65816

    PatriotInvasion

    Joined:
    Jul 18, 2010
    Location:
    Boston, MA
    #1
    So there used to be an option to clear cache, but now there are only buttons to clear history, and clear cookies & data.

    I have done both as well as gone to Advanced and deleted all data, but emails that I've sent and other stuff is auto-suggesting when typing in the address bar in Safari (ex. typing "gmail" is showing subject lines of past email messages).

    How do I completely clear this out??? :confused:
     
  2. macrumors 6502a

    Joined:
    Nov 16, 2011
    #2
    At the bottom of the Safari settings is Advanced->Website Data, and at the bottom of that screen is Remove All Website Data. Did you try that?

    Regards,
    Tom
     
  3. thread starter macrumors 65816

    PatriotInvasion

    Joined:
    Jul 18, 2010
    Location:
    Boston, MA
    #3
    Yes, I did that and Safari is sill suggesting URLs when I start typing "gmail" that show previous emails I've sent. I need this cleared out.
     
  4. macrumors member

    Joined:
    Oct 7, 2011
    #4
    I seem to remember runing into this with iOS5.

    I closed Safari in the multi-task menu as well and then went in and cleared everything successfully.
     
  5. thread starter macrumors 65816

    PatriotInvasion

    Joined:
    Jul 18, 2010
    Location:
    Boston, MA
    #5
    Closing the app doesn't fix it. It's still somehow pulling data from somewhere and with no "clear cache" button in settings, I'm wondering if I'm missing something. Where could it be pulling data that would suggest the URL of a gmail message?
     
  6. thread starter macrumors 65816

    PatriotInvasion

    Joined:
    Jul 18, 2010
    Location:
    Boston, MA
    #6
    I know Safari 6 on the Mac made it complicated to clear the cache by forcing you to turn on the Developer Menu to see the option.

    There is a new option in iOS 6 Safari settings (advanced) that references Web Inspector and says to connect to a Mac and use the Developer Menu to inspect. Perhaps that is the new, more complicated way to truly clear out cache?:confused:
     
  7. macrumors 6502a

    Joined:
    Jun 30, 2007
    Location:
    Denver/Boulder, CO
    #7
    Sounds like history to me, but you said you already did that via Settings? :confused: Go to the root of your bookmarks, and verify that the History folder is actually empty - maybe the Clear History didn't take? The only other thing I could think of is somehow your gmails have gotten bookmarked. (When I use the Clear History button, the only suggestions that show up in the address bar are sites I've bookmarked.)
     
  8. macrumors 6502a

    Joined:
    Mar 25, 2009
    #8
    what if you turn on private browsing after clearning history and data
     
  9. thread starter macrumors 65816

    PatriotInvasion

    Joined:
    Jul 18, 2010
    Location:
    Boston, MA
    #9
    I found what was causing this, but it may be another can of worms. The auto suggestion of URLS referencing my gmail messages are being pulled from iCloud Tabs.

    Essentially, it's suggesting a tab that it *thinks* is open on my iMac at home. However, my iMac at home is shut down without Safari open. It seems that this may be a bug with iCloud Tabs as it is not clearing them out properly.

    Thanks for everyone's help. I'll try to figure this other issue out over the weekend.

    Also - here's a thread that references this iCloud Tabs issue - http://forums.macrumors.com/showthread.php?p=15906118#post15906118
     
  10. macrumors 6502a

    Joined:
    Jun 30, 2007
    Location:
    Denver/Boulder, CO
    #10
    Hmm... Settings->iCloud and there's an option to turn off iCloud for Safari.

    It prompts me:
    "What would you like to do with the previously synced iCloud Safari data on your iPhone?
    - Keep on My iPhone
    - Delete from My iPhone"
     
  11. thread starter macrumors 65816

    PatriotInvasion

    Joined:
    Jul 18, 2010
    Location:
    Boston, MA
    #11
    That doesn't clear it. You have to turn on the other device (my iMac in this case) and open Safari again. At that point, my iPhone resets the iCloud Tabs to what is currently open. Seems like some sort of caching bug of tabs even when they are closed. Idk.
     

Share This Page