How do I get AM and PM suffixes on my Mac's clock?

Discussion in 'macOS' started by Will Cheyney, Jan 10, 2006.

  1. Will Cheyney macrumors 6502a

    Will Cheyney

    Joined:
    Jul 13, 2005
    Location:
    United Kingdom
    #1
    I would very much like for my Mac's clock to have AM and PM suffixes, like so:

    [​IMG]

    However, I can't seem to turn the option to have such a feature. It is greyed out in my System preferences, even when I uncheck the 'Use 24-hour clock' option':

    [​IMG]


    Can anyone explain why this might be, and how I can enable such a feature?
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
  3. Will Cheyney thread starter macrumors 6502a

    Will Cheyney

    Joined:
    Jul 13, 2005
    Location:
    United Kingdom
    #3
    ;) I realise that!
     
  4. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #4
    I think there are some International settings that can override your Date/Time settings. From the "Date & Time" panel of "Date & Time," click on "Open International." Check to see that things under "Times" look like they'll let you display AM and PM.
     
  5. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #5
    Sorry I missed that. You won't get it back until you uncheck the 24 hour clock box though. Maybe uncheck it, restart and see if you get it back. :)
     
  6. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #6
    I can display AM/PM for 24-hour time. I know it shouldn't be allowed, but the OS will let you do it.
     

    Attached Files:

  7. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #7
    Okay, coolness. I always thought we couldn't. I guess a permission repair would be a nice start then. :)
     
  8. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #8
    I still think it's simply an International preference overriding the Date & Time preference pane. No real need to repair permissions just yet.
     
  9. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #9
    You're probably right but I'm not finding anything that could turn this off yet... Well, at least nothing to turn off the option of AM/PM.
     
  10. Will Cheyney thread starter macrumors 6502a

    Will Cheyney

    Joined:
    Jul 13, 2005
    Location:
    United Kingdom
    #10
    Haha, it's a UK thing. If the region is set to the UK in the International preference pane you can't seem to have AM/PM suffixes... well, not that I have managed anyway! Anyone else had better luck?
     
  11. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #11
    You guys always were a bit behind. :D

    That's a bizarre fault though.
     
  12. Will Cheyney thread starter macrumors 6502a

    Will Cheyney

    Joined:
    Jul 13, 2005
    Location:
    United Kingdom
    #12
    Ah ha!
    Cracked it! You need to customise the clocks format with the International preference pane!
     

    Attached Files:

Share This Page