How Do I Get QT Pro to Deinterlace for Export?

Discussion in 'Mac Apps and Mac App Store' started by Makosuke, Sep 1, 2005.

  1. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #1
    The title says it all; I want to export a video clip from a DV source file to a smaller MP4 file, but regardless of the Deinterlace and Single Field setting in the Movie Properties window, the exported file ends up interlaced, which is rather ugly. I'm relatively sure that QT6 did this properly, so is this a stupid bug in QT7 or am I missing something?

    How the $#!% do I set it to deinterlace the video before scaling and recompressing?
     
  2. Lacero macrumors 604

    Lacero

    Joined:
    Jan 20, 2005
    #2
    QT7 bug. I have the same problem with encoding to H.264. It works sometimes which makes the problem difficult to track down.
     
  3. Makosuke thread starter macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #3
    Works sometimes? Meaning that if I keep trying, eventually I'll get a deinterlaced file? So far out of at least a half-dozen test clips not one turned out right for me. Please tell me, what are you doing when you get it to work at all?

    There's always the H.264 encoder in ffmpegX, but its encoders seem to like to crash on large .dv files. Maybe if I let QT do the decoding...

    (By the way, I love your av--that's EXACTLY how I'm feeling about this.)
     
  4. Lacero macrumors 604

    Lacero

    Joined:
    Jan 20, 2005
    #4
    I did it back in May, and haven't bothered encoding again. LOL. Too much trouble. I use Compressor 2 or Cleaner 6, if you have those programs.
     
  5. Makosuke thread starter macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #5
    Ok, thanks anyway. No, I pretty much only have QT Pro, and until now that's been enough for my needs--I'm not a professional. Even iMovie's MP4 export neglects to deinterlace the video... yeargh.

    Anybody else got any suggestions?
     
  6. Makosuke thread starter macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #6
    For future reference if somebody searches up this thread, there are TWO tricks to getting this to work.

    #1: Save a reference movie of the .dv stream(s) with the deinterlace, high quality, and I suppose single frame (is this necessary? a good idea?) options checked. Exporting from this reference movie will work from a deinterlaced source, but only if...

    #2: SET THE FRAME RATE MANUALLY to 29.97 (or whatever). The mistake I was making was leaving the framerate at "automatic" which QT apparently interprets to mean "60 interlaced fields per second)". This is true regardless of the format, and whether you export from iMovie or QT Pro, so far as I can tell. By manually setting it to 29.97 fps, it worked as it should have.

    I suppose the latter of the two makes sense, but it's pretty crazy that it's that complicated.

    Also worth noting: So far as I can tell, the "MP4" export option doesn't anywhere allow you to select the framerate, so I had to do a .MOV with H.264 video and AAC audio, then when that was done export it to an MP4 file using "Passthrough" for audio and video.

    Argh, that was more trouble than it should have been--why on EARTH doesn't at least iMovie HD do this automatically? Older versions did...
     
  7. Makosuke thread starter macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #7
    Egad, this is ridiculous. The exact same file that I had working yesterday, exporting with the exact same settings, is now not deinterlaced.

    I've used computers long enough to be used to the quirks they spit at you, but seriously, how can an identical operation produce different results on two different days? Especially when it's something that shouldn't be nearly this difficult to begin with.

    The endless test-encodes continue...

    (Well, at least the files that did finally encode correctly, before it stopped working again, look fantastic--full-frame resolution from shaky handheld MiniDV source looking quite sharp at 380kbps. I do love H.264.)
     
  8. Lacero macrumors 604

    Lacero

    Joined:
    Jan 20, 2005
    #8
    Yep. Like I said, it happens sometimes and it's difficult to know what went wrong. It's a bug I tells ya.
     
  9. rendezvouscp macrumors 68000

    Joined:
    Aug 20, 2003
    Location:
    Long Beach, California
    #9
    Makosuke, you say you're exporting to h.264, so I'm curious if you've been experiencing the "gray bug" that I've complained about in this thread? Also, why do you change the file name to .mp4 instead of leaving it as .mov? I'm just curious if there's any advantage to doing that.
    -Chase
     
  10. Makosuke thread starter macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #10
    Mmkay, I'm pretty sure I've FINALLY figured out what needs to be done to get a properly deinterlaced movie, and what I'd inadvertently changed; the trick is you can't use the "size" section of the .MOV file exporter to set the size, you need to set it in the size section of the movie's properties and export at "current size". Now that's just stupid.

    Summary:

    1) Create a reference movie referencing the DV clip.
    2) Set the Deinterlace flag on the reference movie and set it to your desired export size, then save it.
    3) Export using the QT Movie file exporter, and be sure to leave the size at "current" but set the framerate manually to 29.97. (I'm not 100% sure now, but I think exporting directly to MP4 will screw it up.)
    4) If you want an MP4 file, export the finished product as MP4 and set the audio and video as "Passthrough".

    Ugh. At least I'm done now, and the result looks good--roughly twice the quality of an equivalent bitrate WMV or XviD file.

    The colors do look slightly lighter in Safari compared to Camino, but it's certainly not bad enough that I would have noticed it had you not pointed it out. I wonder if that has to do with my monitor calibration (which, comparing, isn't wildly different from the default RGB, just a little darker--it's a new Cinema Display).

    As for MP4, I'm not changing the extension; I'd originally intended to export as an .mp4 file instead of a .mov, but it occurred to me that they're basically identical and VLC (they only thing I'm familiar with that handles H.264 and AAC other than QT7) plays both equally well anyway, so I'm just dealing with straight QT .movs now.
     

Share This Page