how do i get tv to full screen mode with vlc?

Discussion in 'Mac Apps and Mac App Store' started by jayd, Dec 8, 2006.

  1. jayd macrumors member

    Joined:
    Oct 24, 2006
    #1
    i have my laptop hooked up to my tv so i can watch a movie on the tv through vlc. if i click fit to screen mode it works fine on the tv but if i click fullscreen it dissapears from the tv and only shows the fullscreen movie on my laptop. how do i watch a movie in fullscreen mode on the tv through vlc on my computer?
     
  2. glennp macrumors member

    Joined:
    Aug 7, 2006
    Location:
    Washington, DC
    #2
    Put the Controller window on the screen you want the full screen video to play on, the select the Full Screen mode.
     
  3. jayd thread starter macrumors member

    Joined:
    Oct 24, 2006
    #3
    i did that already. i connected it to the tv, dragged the controller window to the right of the laptop screen untill i see it on the tv. then when i hit fullscreen mode it dissapears from the tv and goes back on the laptop to fullscreen.
     
  4. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #4
    There's a menu option to select the video device (I think it's Video -> Device). Pick the TV then go full screen. You can leave the controller on the laptop.

    B
     
  5. d wade macrumors 65816

    d wade

    Joined:
    Jun 27, 2006
    Location:
    Boca Raton, FL
  6. diametric macrumors regular

    diametric

    Joined:
    Jul 4, 2006
    Location:
    Sydney
    #6
    Wow, you must just ace comprehension exams.

    And moving on, thanks for the info, I've been wandering about this too.
     
  7. jayd thread starter macrumors member

    Joined:
    Oct 24, 2006
    #7
    balamw, nothing says device under video and i cant find anything that says tv anywhere. and apple f doesn't work. this is what i see.
    [​IMG]
    i tried clicking fullscreen video output but all that does is start up the laptop automaticly in fullscreen.
    [​IMG]
    [​IMG]
     
  8. jayd thread starter macrumors member

    Joined:
    Oct 24, 2006
    #8
    oooooo, now i understand what you were talking about. it wont let me select video device. its in grey.
    [​IMG]
    i can only get it like this on the tv
    [​IMG]
     
  9. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #9
    Weird, seems like VLC doesn't recognize your TV as a valid video device. What does the Displays part of System Preferences look like?

    B
     
  10. jayd thread starter macrumors member

    Joined:
    Oct 24, 2006
    #10
    look at the pictures right above my last post. i think thats what you talking about
     
  11. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #11
    No I'm talking about OS X not VLC, the little monitor in the menu bar will take you there...

    B
     
  12. jayd thread starter macrumors member

    Joined:
    Oct 24, 2006
  13. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
  14. jayd thread starter macrumors member

    Joined:
    Oct 24, 2006
    #14
    [​IMG]
    [​IMG]
    [​IMG]
    these are the options in display. i cant figure out what to do. thank you for taking the time to help me with this.
     
  15. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #15
    Weird, the middle picture definitely shows that the Mac thinks you have two displays and you're not mirroring between them.

    There should be a similar window on your TV. Can you post a screenshot similar to the first one for that.

    BTW. You might want to crop those images a bit so we don't have to see your choice of content. :eek: :eek: :D :p

    B
     
  16. jayd thread starter macrumors member

    Joined:
    Oct 24, 2006
    #16
    i dont understand what you want me to show you a picture of next?
     
  17. expergo macrumors regular

    Joined:
    Nov 21, 2004
    #17
    I think I had this problem with my ibook. The "video device" would be grayed out sometimes. I forgot how I fixed it though.

    I'll check it out later when I get my ibook back. I think it had something to do with how I selected the movie.
     
  18. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #18
    Could it be that you're staring VLC before you connect the TV?

    (i.e. by the time VLC looks for video devices, there's only one?)

    B
     
  19. live4ever macrumors 6502a

    Joined:
    Aug 13, 2003
    Location:
    Thunder Bay, ON
    #19
    Yep, it won't work unless the display is detected before VLC is started.
     
  20. jayd thread starter macrumors member

    Joined:
    Oct 24, 2006
    #20
    thats not it because i quit vlc and tried it again. i can get the tv to fullscreen with mplayer but not vlc.
     
  21. bankshot macrumors 65816

    bankshot

    Joined:
    Jan 23, 2003
    Location:
    Southern California
    #21
    In the Displays preference pane, you need to drag the menubar to the TV screen, under the Arrangement tab. I think VLC only allows you to go completely full-screen on the main screen, which is whatever one has the menubar. Kind of annoying. ;)
     
  22. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #22
    That's not how it works for me on 0.8.5 I can select the TV as the video device in VLC, leave the VLC controls and menubar on the iMac's screen and go full screen. Even QT allows you to select the display for full screen. Only Front Row will only use the primary (menubar) display.

    jayd, VLC was updated today, have you checked if the new version makes a difference?

    B
     
  23. jayd thread starter macrumors member

    Joined:
    Oct 24, 2006
    #23
    i figured out how to do it. i went to arrangements and clicked mirror display and the tv just matches whats on the computer screen. i just have to uncheck the box when im done watching the movie. thank you guys so much for taking the time to help me. i love this forum.
     

Share This Page