How do I install Diablo 2 onto macosx?

Discussion in 'Games' started by WillMak, Sep 13, 2005.

  1. WillMak macrumors 6502a

    Joined:
    Jul 29, 2005
    #1
    I have Diablo version 1.0 that I bought many many years ago. I just realised that it's mac compatible as well so I've been trying to install it on my new ibook. However, I can't get it to install. I downloaded this: http://www.apple.com/downloads/macosx/games/demos_updates/diabloii.html
    the native osx installer but I get errors during the installation ( The file "/Volumes/Diablo II Install/Support/Diablo II Game Data" could not be read, because an error -36 occurred. (InstallerFile::Read)
    ). Anyone have any solutions?
     
  2. reh macrumors 6502a

    Joined:
    Oct 24, 2003
    Location:
    Arkansas
    #2
    You can't use that file.
     
  3. WinterMute Moderator emeritus

    WinterMute

    Joined:
    Jan 19, 2003
    Location:
    London, England
    #3
    Do a Goooogle search for Blizzard (or Diablo 2) and find the Blizzard site, then look for the OSX installer for the version of the game you have.

    I have D2 Lord of destruction expansion running fine under 10.4.2 currently.
     
  4. topgunn macrumors 65816

    topgunn

    Joined:
    Nov 5, 2004
    Location:
    Texas
    #4
    If you are correct in saying that you have Diablo version 1.0, then the Diablo II carbon installer won't work for you since it is for Diablo II.

    The original Diablo will only run under classic mode and I am not 100% certain it will evn install there. Diablo II will install in OSX but you need to download the OSX Installer (which it appears you already have). Once you have the installer, run it. It will tell you which disks to insert after you have told it what you want to install.
     
  5. WillMak thread starter macrumors 6502a

    Joined:
    Jul 29, 2005
    #5
    it's just a typo, I have version 1.0 diablo II retail.
     
  6. CorvusCamenarum macrumors 65816

    CorvusCamenarum

    Joined:
    Dec 16, 2004
    Location:
    Birmingham, AL
    #6
    Another possible solution - install in Classic, then download the OS X native application and copy it all out of Classic.
     
  7. JonathanW macrumors newbie

    Joined:
    Dec 6, 2005
    #7
    I've had the same problem as WillMak, and I shouldn't even have to touch classic if I download the Mac OS X native installer. My friend used the installer on his new ibook, and it works fine. This is the third thread I have found on the internet with the same exact problem (error-36). Has anyone found a way to get around it or have any good suggestions. The error occurs for me while the Play Disc is installing and when the progress bar says something along the lines of "Play Disc: Installing Music"
    Thanks
     
  8. bokdol macrumors 6502a

    bokdol

    Joined:
    Jul 23, 2002
    Location:
    VA
    #8
    find a different play disk.. same ting happen to me but a diffferent version of the play disk worked,, i dont know why... it seems like there are different versions of the play disk and some will install and some wont.
     
  9. Lord Blackadder macrumors G5

    Lord Blackadder

    Joined:
    May 7, 2004
    Location:
    Sod off
    #9
    I've had no problems with the OS X installer, but my Diablo II disc is version 1.04 or something like that; certainly later than 1.0.

    It's times like these that I'm glad I have a dual-boot capable Mac, but in your case I'm not sure what to do - perhaps look for a used Diablo II disc at a used video game store?
     
  10. louis_sx macrumors regular

    Joined:
    Jul 6, 2005
    Location:
    International House of Louis
    #10
    Diablo II's 1.0 disc was NOT hybrid. I had to re-buy the game when I wanted to play it on my Mac instead of my PC because I bought it very early on and it was PC-only.
     
  11. floyde macrumors 6502a

    floyde

    Joined:
    Apr 7, 2005
    Location:
    Monterrey, México
    #11
    Ok, so post-1.0 Diablo 2 discs are hybryd but I need to get an installer? I once tried my old Diablo 2 discs on my Powerbook but I didn't see anything Mac-like so I assumed it was the older version, but maybe it isn't...:eek:
     
  12. louis_sx macrumors regular

    Joined:
    Jul 6, 2005
    Location:
    International House of Louis
    #12
    Even if you go out and buy Diablo II today you will not get the OS X Carbon version of DII, just the classc app version. The installer will prompt you for the discs to get the data, but the installer contains the app itself, for both with and without the Lord of Destruction expansion.
     
  13. Lord Blackadder macrumors G5

    Lord Blackadder

    Joined:
    May 7, 2004
    Location:
    Sod off
    #13
    Intersting point. To the OP: is there anything on your discs that specifically says that it is Mac compatible? Maybe you need a later version of the game.

    Anyway, Diablo II is pretty easy to find used nowadays for cheap - I see it all the time at Half Price Books for around $10. you might have to buy it again to get a hybrid disc.
     
  14. bokdol macrumors 6502a

    bokdol

    Joined:
    Jul 23, 2002
    Location:
    VA
    #14
    i know the newest battle chest works. a friend bought it and it had the osx installer on it. but i know nothing about the single packs.
     

Share This Page