How do I keep itunes from importing the same song twice/delete all these extra copies

Discussion in 'Mac Apps and Mac App Store' started by whw5, Oct 18, 2004.

  1. macrumors regular

    Joined:
    Feb 27, 2004
    Location:
    Atlanta
    #1
    For some strange reason, multiple copies of almost every song I own are stored on my computer. Having them there is not much of a pain, even though they do take up a good deal of space. However, how do I keep itunes from importing these extra songs twice? Its a real pain because my music library has 2 or 3 copies of every song. Is there a way to keep itunes from doing this or do I have to go through by had and do this manually? Any help is great!!!
     
  2. macrumors 603

    wordmunger

    Joined:
    Sep 3, 2003
    Location:
    North Carolina
    #2
    Whenever I rip a CD, iTunes prompts me if it turns out I had already imported it. Maybe something's wrong with your preferences? Do you specify copying the music to the iTunes folder when adding a song to your library? That might be it.
     
  3. macrumors 68040

    decksnap

    Joined:
    Apr 11, 2003
    #3
    If you have the preference set to 'keep iTunes music organized' and 'copy music to iTunes folder when importing' you shouldn't have duplicate problems, so long as you are using correct names.
     
  4. macrumors 601

    cb911

    Joined:
    Mar 12, 2002
    Location:
    BrisVegas, Australia
    #4
    if, like me, you dont' have your iTunes music folder 'organized' (because you dont' want each single track going in it's own folder, especially when it doesnt' have a proper album name, making it impossible to find...) there are a few sites out there that have some nifty AppleScripts to deal with all sorts of situations in iTunes. may be a script that you could use.
     

Share This Page