How do I prevent acrobat from hijacking Safari?

Discussion in 'Mac Apps and Mac App Store' started by khammack, Mar 24, 2005.

  1. khammack macrumors regular

    Joined:
    Sep 28, 2004
    Location:
    Portland, OR
    #1
    In an apparent lapse of judgement, I installed acrobat reader on my new powerbook because I was having trouble reading a pdf file with "preview" (which generally is of excellent quality).

    Now acrobat reader hijacks safari every time I click on a pdf file online. I didn't ask for this dammit. What I desire is for preview to remain the default, external pdf viewer on my system. At the same time, I don't want to just trash acrobat reader; if I have trouble with a pdf file I can launch adobe's abomination on my own, thank you very much. I do not want an embedded pdf viewer, nor do I want adobe to be the default for pdfs.

    As an aside, my disdain for adobe's reader software began on linux. The native pdf viewers for linux are generally better software, but you have to load acrobat reader from time to time due to stupid "proprietary" extensions that some programs load into some pdf files (hey, wasn't this supposed to be an open standard?). But I has assumed that this was merely due to free software mixing with corporate software like oil and water.

    Edit: I had already discovered "Preferences->Internet->Display pdf in browser using". This didn't work at first, then I thought to restart Safari after having posted here. That seemed to work. Then I started Adobe reader again, and (surprise surprise) the box was checked again. No need to restart Safari, Adobe is once again hijacking my browser! This is repeatable. I can explicitly ask adobe not to embed itself in safari, and it will obey...until the next time acroread is launched.

    Thanks,
    -kev
     
  2. mduser63 macrumors 68040

    mduser63

    Joined:
    Nov 9, 2004
    Location:
    Salt Lake City, UT
    #2
    I had the same problem, except that I wanted Safari to continue displaying PDFs with the PDF Browser Plugin. I fixed it by going into Library -> Internet Plug-ins and deleting the Acrobat Reader plugin. Now Safari once again uses PDF Browser Plugin.
     
  3. iLikeMyiMac macrumors 6502a

    iLikeMyiMac

    Joined:
    Jul 17, 2004
    Location:
    St. Louis
    #3
    You can also go to preferences the Adobe Reader and uncheck the appropriate box.
     

    Attached Files:

  4. khammack thread starter macrumors regular

    Joined:
    Sep 28, 2004
    Location:
    Portland, OR
    #4
    I was about to reply and suggest that you read the last paragraph of my post, where I did that. But then I noticed that you have "Check browser settings" unchecked as well. I failed to do that, which must be why adobe kept resetting my preference every time it loaded.

    Now I can reload acrobat and safari several times, and it still respects my setting. So I guess I'll hold off on deleting the plugin; it may be useful again someday.

    Thanks for the help, I didn't realize that plugins were stored in the Library folders either.

    -kev
     

Share This Page