How do I stop apps downloading to all devices?

Discussion in 'iOS 6' started by dj9928, Feb 3, 2012.

  1. macrumors member

    Joined:
    Jan 17, 2005
    Location:
    Ireland
    #1
    At the moment if I download an app from my iPhone it will download to iTunes aswell, when I sync my sons iPod it also appears in it as well. How do I stop this? My son has a different iCloud ID he just uses my iTunes account to buy apps etc
     
  2. macrumors 6502a

    tyr2

    Joined:
    May 6, 2006
    Location:
    Leeds, UK
    #2
    Connect the iPod to iTunes, select it, go to the 'apps' tab. Untick 'automatically sync new apps'.

    If you don't want it to automatically download to iTunes at all, go to 'Preferences', 'Store' and untick 'Apps' in 'automatic downloads'
     
  3. macrumors newbie

    Joined:
    Feb 4, 2012
    #3
    Similar situation that I need help with

    I just recently upgraded to an iPhone 4S. Since that time, anytime an app is downloaded onto any of our 4 devices, it is pushed to ALL of the devices. How do I stop this from happening? I'm assuming it's somewhere in the settings. I also do have iCloud activated, but the only thing active on it is "Find my iPhone". Any help would be greatly appreciated.
     
  4. macrumors G5

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #4
    Same as above, but connect each device in turn and select the option "DO NOt Automatically sync new apps"
     
  5. macrumors 6502

    Joined:
    Feb 26, 2011
    #5
    Goto settings - store on each device (you don't have to connect to itunes) and select your syncing options for books, music and apps.

    The previous options mentioned in this thread prevent syncing when you connect to itunes on pc/mac, I don't think that was the exact problem you are having.
     
  6. macrumors newbie

    Joined:
    Oct 13, 2010
  7. macrumors newbie

    Joined:
    Jul 18, 2013
    #7
    Please I think it's the currect answer

    please open iTunes and go to itunes preferences, a new window will open and click on store tab and unckeck Apps and click OK. I think it will sort out your problem.... Thankx
     

Share This Page