How stop Visual Basic macros error message at opening Excel?

Discussion in 'Mac Apps and Mac App Store' started by seleneS, May 5, 2011.

  1. seleneS
    Expand Collapse
    macrumors member

    Joined:
    Jul 28, 2010
    #1
    I've got this message
    "This file contains Visual Basic macros. The macros that have been dislabled."​
    every time I open Excel, even just opening Excel with no file. How can I stop it? Thanks!
     

    Attached Files:

  2. robbieduncan
    Expand Collapse
    Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #2
    Which version of Excel are you running? If it's 2004 that message is probably due to it not support VBA. No idea if it can be turned off but upgrading to the current version that does support VBA would probably get rid of it...
     
  3. seleneS
    Expand Collapse
    thread starter macrumors member

    Joined:
    Jul 28, 2010
    #3
    I'm using 2011, version 14.0.2. I think it's the latest version.
     
  4. robbieduncan
    Expand Collapse
    Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #4
    What are you're macro security settings in Excel preferences?
     

    Attached Files:

  5. MisterMe
    Expand Collapse
    macrumors G4

    Joined:
    Jul 17, 2002
    Location:
    USA
    #5
    The OP's posted screenshot is clearly from Excel 2011. Also, Excel 2004 most definitely supports VBA.
     
  6. seleneS
    Expand Collapse
    thread starter macrumors member

    Joined:
    Jul 28, 2010
    #6
    The error message shows up for both setting (warning chosen or not):(
     
  7. Pyrotechnic
    Expand Collapse
    macrumors 6502

    Pyrotechnic

    Joined:
    Feb 28, 2009
    Location:
    United Kingdom
    #7
    Did anyone find a solution, I now have the same issue ?
     
  8. hanguolaohu
    Expand Collapse
    macrumors regular

    Joined:
    Mar 5, 2007
    #8
    The Solution

    Found the answer on Microsoft Forums.

    1. Close Excel.
    2. Go to Applications/Microsoft Office 2011/Office/Startup/Excel.
    3. If there are any files in the Excel folder, delete them.

    Problem solved for me.
     
  9. Enzedder
    Expand Collapse
    macrumors newbie

    Joined:
    Feb 19, 2012
    #9
    VBA installation option

    I had this issue and found that the VBA Macro option hadn't been installed when Office was first set up. Run the Office setup again and choose the 'Customize' option (about 3rd dialogue window into the routine). Scroll down and look for the VBA option and select it (it should say install), make sure everything else is unticked (skipped). I think you'll find it works after that. :D
     
  10. hanguolaohu
    Expand Collapse
    macrumors regular

    Joined:
    Mar 5, 2007
  11. cdbeshore
    Expand Collapse
    macrumors newbie

    Joined:
    Jul 27, 2008
    #11
    Dymo

    hanguolaohu's suggestion worked for me. Turned out that an update to Dymo Label had added something in there.
     
  12. hanguolaohu
    Expand Collapse
    macrumors regular

    Joined:
    Mar 5, 2007

Share This Page