How to auto-reconnect to a wireless network?

Discussion in 'Mac Basics and Help' started by AlbinoPigeon, Nov 11, 2006.

  1. AlbinoPigeon macrumors member

    Joined:
    Jan 1, 2004
    Location:
    Vancouver, BC
    #1
    I've been having a problem where my internet connection will drop after a while. This is annoying when I leave it unattended to DL a large file. Is there anything out there that will simply reconnect the airport connection automatically? Thanks!

    BTW: It's not like my wireless router dies or anything, when I come back to the comp and find it disconnected I simply manually reconnect and everything is fine.
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Are there other machines on your network that get the same behaviour? Could it be a security precaution on the router's part that kicks you off after a certain time, because your machine should stay connected until you either manually disconnect it, it falls asleep or it gets shut down. Is it falling asleep? :)
     
  3. Reflow macrumors 68000

    Reflow

    Joined:
    Mar 30, 2005
    Location:
    NJ/PHL
    #3
    Try to download a program called netstumbler that can see what other wireless networks are out there. As in doing a wireless channel change might help

    Click here for netstumbler
     
  4. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #4
    On a similar note (and possibly the same solution), how do you get OS X to automatically join a network at boot?
     
  5. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #5
    Nermal, it should do that by default. If you're connecting to the wrong network at startup each time then you can opt to only automatically connect to Preferred Networks in the AirPort pane of System Preferences. The order of that list is what your Mac will try to connect to first off.
     
  6. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #6
    It was set to "By default, join Automatic" - I have changed this to Preferred Networks. I'm not about to reboot now, but I'll try to remember to post back when I do.

    The problem was it not connecting to any network at all, it wasn't connecting to the wrong one.
     
  7. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #7
    There was a bug with some Intel machines doing this. I think the workaround was to set it up to connect to Preferred Networks, delete all your entries, re-add them, and then work from there. I recommend closing System Preferences between each change. In other words, delete the entries, close System Preferences, reopen System Preferences, re-add the entries, close System Preferences, go on your merry way. After this I believe you can change it back to Automatic too. Did any of that make sense? :)
     
  8. AlbinoPigeon thread starter macrumors member

    Joined:
    Jan 1, 2004
    Location:
    Vancouver, BC
    #8
    Nope, it's not falling asleep. And to my knowledge there isn't a time out feature on my router. But...even if there was, is there a way to get it to auto-reconnect? Having to constantly monitor whether the computer is still connected is annoying, especially when the network it still available. And, in case, I am not having the same problem as nermal. There are about 2-3 other networks around me, could that be a problem?
     
  9. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #9
    The other networks could be a problem if you're getting a lot of interference. What sort of reception do you get in the places where this disconnecting happens? Also, I don't think your problem is the same as Nermal's, FWIW. :)
     
  10. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #10
    Done. I'll know whether it worked next time I reboot :)
     
  11. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
  12. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
  13. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
  14. AlbinoPigeon thread starter macrumors member

    Joined:
    Jan 1, 2004
    Location:
    Vancouver, BC
    #14
    There's great reception, the router is in my room. I think what may be happening is that the router goes offline for a minute or so, and then when it comes back, there's no connection. So how can I get the system to auto-connect?
     
  15. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
  16. brucepet macrumors newbie

    Joined:
    Sep 19, 2006
    #16
    Intel iMAC doesn't connect to Preferred Network

    Thanks to you Mad Jew I was able to fix my problem. Each time I booted my iMAC I was unable to connect to my home wireless network. I had to recheck the home network in the list of available networks to gain connectivity. I tried your fix about three times and now it works. Upon turning on the machine I have automatic connectivity. Thanks for your help.
    Bruce
     
  17. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
  18. jmxhgyZN8wK7 macrumors newbie

    Joined:
    Jan 2, 2009
    #18
    I'm having the same problem as AlbinoPigeon.

    Can anyone help? (No one seems to have solved this problem yet...)
     

Share This Page