How to configure Mac as a proxy server (not to use a proxy server!)

Discussion in 'Mac OS X Server, Xserve, and Networking' started by unfrostedpoptar, Aug 8, 2012.

  1. macrumors regular

    Jan 29, 2010
    Hi all.

    I thought this would be easy, but I can't find what I'm looking for.

    I have an iMac and an MBA - both running 10.8. I use the iMac to connect to the VPN of my company using Cisco Anyconnect. They have very tight security settings, so everything that's not on 192.168.0-2.x has to go through the VPN - and therefore through my company's network. So, when I'm connected to work, any email, web, etc Internet traffic has to go from the iMac, to my company, and then to the Internet. Besides security and privacy issues, this makes things slow as hell. Without VPN, I can get about 20-30Mbps down. When it's on, it drops to 3Mbps!

    So, I thought I would use my MBA, or an old WinXP laptop I have sitting around and have it run as a proxy server. Since they're on my local 192.168.x network, I could set my iMac to use this for some apps and bypass the VPN.

    Make sense? Anyway, every program and info website I've found is for setting up a Mac to connect to a proxy server on the Internet to secure and/or hide my access. That's great, but it's not what I'm looking for right now.

    How can I make my MBA or WinXP box be a proxy server for the iMac?


  2. macrumors 601

    Aug 15, 2005
    If you currently cannot stop the traffic from going through the VPN, adding a proxy will not prevent it either. Your proxy server is not going to be able to decrypt the packet and bypass the VPN.
  3. macrumors regular

    Aug 12, 2008
    Cambridge, UK
    You'll probably want to install something like Squid on your Mac. The squid website has plenty of FAQs and examples to get you going ;)

    Alternatively you could set up the built-in Apache server with mod_proxy
  4. thread starter macrumors regular

    Jan 29, 2010
    Any traffic on 192.168.0-2.x bypasses the VPN. Thats why I need my own proxy server on my own local network for this to work.

Share This Page