How to disable spell check in browser

Discussion in 'Mac Basics and Help' started by farqueue, Oct 29, 2007.

  1. macrumors 6502


    Jun 18, 2006
    How to disable spell check in browser?
    everytime i login using my username or google something like a name safari automatically underlines it saying i spelt it wrong

    its annoying

    how can i turn this featuer off?
  2. Moderator


    Staff Member

    Oct 11, 2005
    The Black Country, England
    Are you sure you want to turn it off? :D
  3. thread starter macrumors 6502


    Jun 18, 2006
    lol... yes:D
  4. macrumors 603


    Feb 2, 2007
    51.50024, -0.12662
    easy peezy japanesey... hehe i just watched The Shawshank Redemption... if you dont get it dont worry

    anyway back on topic. to disable spell checking in safari:

    edit -> spelling and grammar -> check spelling while typing
  5. macrumors P6

    IJ Reilly

    Jul 16, 2002
    I'm surprised that you've got this issue. I have yet to see a user name box that invokes the spell checker. And the Google search box in Safari certainly does not.
  6. macrumors newbie

    Oct 31, 2007
    Just control-click inside the textbox and a contextual menu will appear.
    Then select "Spelling and Grammar" and uncheck the "Check Spelling While Typing" option.

    (took me quite a while to figure this out...) :eek:
  7. macrumors newbie

    Mar 8, 2009
    Hi I run the leading spelling website on the web and I'm having trouble with safari. Right now, our solution is to tell people to use a different browser.

    The problem is that the automatic spell checker underlines each word that is spelt wrong, wrecking the test.

    Is there a way for us to label the box: "Do not spell check!"

    Or, does anyone have any clever workarounds for it?

    I'm mayor @

    The site is

Share This Page