How to disable Voice Control?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by AdamLikesMusic, Mar 2, 2011.

  1. AdamLikesMusic
    Expand Collapse
    macrumors 6502

    Joined:
    Jun 3, 2009
    #1
    My old iPod headphones died, so I began using the ones that came with my iPhone. I've never had a problem with voice control until using them, and I assume it has something to do with the microphone on the headphones. Is there a way to disable the feature? I now can't go 30 seconds of running without my music stopping and the damn voice control screen appearing, which is beyond annoying.

    I have a 3gs, if that is of any use.

    Thanks

    (I tried Google searching as well as locally searching these boards, but couldn't get a clear answer)
     
  2. JamesMB
    Expand Collapse
    macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #2
    You can turn "Voice Dial" off...Settings>General>Passcode Lock>Voice dial
     
  3. AdamLikesMusic
    Expand Collapse
    thread starter macrumors 6502

    Joined:
    Jun 3, 2009
    #3
    I've done that, but the problem persists. It happens when my phone is locked, too, which I find rather bothersome.
     
  4. beentomb
    Expand Collapse
    macrumors newbie

    Joined:
    Mar 1, 2011
    #4
    I tried using the voice control and now it pops up every time I start up my computer. How do i disable it. I know the msconfig thing but I cant figure out what application is suppose to be disabled.
     
  5. JamesMB
    Expand Collapse
    macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #5
    What are you talking about?:rolleyes:
     
  6. AdamLikesMusic
    Expand Collapse
    thread starter macrumors 6502

    Joined:
    Jun 3, 2009
    #6
    Bump. Anybody know if it's possible to disable?

    Problem still persists, and now my phone has begun randomly fast-forwarding thanks to apparent voice commands. :mad:
     
  7. vachargerfan
    Expand Collapse
    macrumors regular

    Joined:
    May 28, 2008
    #7
    Maybe try restoring your phone. If you do that and it still happens then maybe you have a hardware problem
     
  8. AdamLikesMusic
    Expand Collapse
    thread starter macrumors 6502

    Joined:
    Jun 3, 2009
    #8
    Restoring to what, though? I'm sure this is a problem I would've always had, but I've only just realized it as I've just begun using headphones that have a microphone on them.

    I disabled voice dialing as was mentioned in this thread, however I'm not sure of how to disable voice controls altogether.
     
  9. JamesMB
    Expand Collapse
    macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #9
    That translates into..."I don't know what is wrong so restore it and then take it to Apple.:D
     
  10. AdamLikesMusic
    Expand Collapse
    thread starter macrumors 6502

    Joined:
    Jun 3, 2009
    #10

    Well then, I suppose I'll be making a trip to the Apple store this weekend. I just figured I'd see if there was an on/off switch or something for voice controls, rather than make an appointment with them only to find out it was as easy as toggling a setting. Y'dig? ;)
     
  11. iluvifone
    Expand Collapse
    macrumors 6502

    Joined:
    Jun 28, 2010
    #11
  12. Gin Gin
    Expand Collapse
    macrumors regular

    Gin Gin

    Joined:
    Jun 22, 2009
    #12
    Are you sure it's not the headphones? It's not likely the microphone in the headphones, but the buttons. Sometimes they short out or something and act like you're pressing the buttons when you're not, that would explain activating the voice controls. Try a different pair.
     
  13. JamesMB
    Expand Collapse
    macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #13
    Sure sounds like the problem is with the earbuds and not the phone....If it were me and I was close to an Apple store, I would probably take it there, but if you are closer to BestBuy, it might be cheaper to just buy a new pair.
     

Share This Page