How to Fix Keyboard Lag w. iOS7 and iPhone 4s

Discussion in 'iOS 7' started by Kavier, Sep 20, 2013.

  1. macrumors 6502a

    Kavier

    Joined:
    Feb 1, 2010
    Location:
    Raleigh, NC
    #1
    I had the worst lag when typing after updating my phone, and I came across this website w/ instructions on how to fix it. Thought I would pass it along in case anyone else has this issue:

    "You just open up the Settings app and navigate to iCloud > Documents & Data. That will open up another window where you’ll see a toggle switch. Turn it off if it already isn’t (i.e., the circle in the toggle switch should be on the left side). After disabling Documents & Data, the keyboard should work just fine."

    Here's a link to the full article as well:

    http://www.gottabemobile.com/2013/09/19/fix-keyboard-lag-ios-7-iphone-4s/
     
  2. macrumors 6502a

    Joined:
    Jun 10, 2013
    #2
    Doesn't make much sense that disabling that would fix the lag.
     
  3. macrumors member

    Joined:
    Oct 2, 2011
  4. macrumors member

    Joined:
    Oct 2, 2011
    #4

    lol!!!!!' I meant mine, not mind....lol.
     
  5. macrumors newbie

    Joined:
    Sep 18, 2013
    #5
    Try disabling the parallax stuff (Settings > General > Accessibility > turn Reduce Motion on) and see if that helps. I have no idea why that would affect the keyboard at all, given that everything else (including the parallax effects!) didn't lag at all, but that's what fixed mine after a day of being unable to type anything.
     
  6. macrumors 65816

    benji888

    Joined:
    Sep 27, 2006
    Location:
    United States
    #6
    It's all in your head
     
  7. macrumors 6502a

    TheRainKing

    Joined:
    Jun 11, 2012
    #7

    lol!!!!!!!! theres an edit button...... lol!!! ;)
     
  8. macrumors 6502a

    sflomenb

    Joined:
    Jul 22, 2011
    Location:
    New Jersey
  9. macrumors 65816

    benji888

    Joined:
    Sep 27, 2006
    Location:
    United States
    #9
    This could do it though. Some things don't necessarily make sense, might not be connected to things in a way we think.

    I've done this on my iPad 1 just now, and it seems to help.

    iPad 1 has the smallest amount of RAM (for an iPad)...I jailbroke my iPad 1 after iOS 6 came out and no update for it. It's still a bit laggy, but, keyboard was horribly laggy. I jailbroke it so I could delete the extra keyboard languages that are invisibly there, using up RAM, causing the lag. I also use a cache wiping app. But, this seems to help also. It kinda sucks, iOS 3 & 4 ran great on it, but, 5 is laggy, safari and other apps can crash (I think they just fill the RAM to the point it gets maxed out and doesn't know what to do, so the app crashes).

    ...It will still sync notes and all that you have checked on, this option is only for apps that use iCloud, which, mostly power users are the only ones using this. Or it may mess things up for someone using a Calendar app? But, in most cases, turning documents & data off won't be a problem.
     
  10. macrumors 65816

    Joined:
    Jul 27, 2012
    Location:
    Hollywood, CA
    #10
    I have a 4S, ZERO LAG on keyboard or anything for that matter.

    I am super impressed with how well 7.0 runs on my 2 year old 4S. Battery is great too. 4S is taking it like a champ.
     
  11. macrumors 6502

    Joined:
    Jan 3, 2012
    #11
    do the ip4 have this option.
     
  12. macrumors 6502

    kwokaaron

    Joined:
    Sep 20, 2013
    #12
    Nope. The iphone 4 doesn't support parallax.
     
  13. thread starter macrumors 6502a

    Kavier

    Joined:
    Feb 1, 2010
    Location:
    Raleigh, NC
    #13
    Didn't make much sense to me either to be honest but it worked. If I turn it back on, my keyboard goes to crap again.
     
  14. macrumors regular

    Joined:
    Sep 21, 2005
    Location:
    Portland, OR
    #14
    Resetting all settings seems to be a fix for some.
     

Share This Page