How to Fix Slow Mac Wireless Internet!

Discussion in 'Mac Basics and Help' started by Dennin, Sep 22, 2007.

  1. macrumors newbie

    Joined:
    Sep 22, 2007
    #1
    For some time now, I have noticed that my Mac's internet is running super slow. I am saying slower than what I see on my PeeCee (Used for gaming such as CSS and Half-Life)! So, I set out on a Google journey to find that a lot of people have been having the same problem with they Airport. It seems that in some Apple updates, the Airports are having issues. So, I tried to fix it and I came up with this wonderful guide. My internet now loads Facebook in 3 sec instead of the 30 sec it was before and I can watch my good old YouTube videos in a flash.

    First, Open your "System Preferences";
    [​IMG]

    Next, go to your "Network" settings;
    [​IMG]

    From there, make sure Airport is highlighted and click "Configure";
    [​IMG]

    Click the "TCP/IP" tab;
    [​IMG]

    Type 4.2.2.1 into the blank DNS Servers box, hit return and type 4.2.2.2 then click the "Apply Now" button like so;
    [​IMG]

    Your internet may restart, but it will come back on right after you hit Apply! And your internet should now return to speeds like it used to have.

    I am running 10.4.10 and I am proud to say my Internet is fast as hell. :apple:

    - Dennin
     
  2. macrumors regular

    bluefiberoptics

    Joined:
    Jul 23, 2005
  3. macrumors newbie

    Joined:
    Jul 12, 2008
    #3
    thaaaaaaaankkkkk youuuuuuuu man!!!!

    This really worked!!!

    A dream come true!

    I mean I don't know if it was luck or what was it, but it seems to be working really really really good!

    can you explain to me what did that do!?
     
  4. macrumors 6502a

    blueflame

    Joined:
    Apr 3, 2003
    Location:
    Studio City
    #4
    make the multicast rate higher, and limit yourself to 802.11n only 5ghz
     
  5. macrumors 65816

    gusious

    Joined:
    Dec 2, 2007
    Location:
    Greece
  6. macrumors 65816

    pjarvi

    Joined:
    Jan 11, 2006
    Location:
    Round Lake, IL
    #6
    You don't have to use 4.2.2.x, you can just use the DNS addresses of your ISP to get similar speed improvements. It's not specific to Airport's either, it affects wired connections as well.
     
  7. macrumors 65816

    Mr_Brightside_@

    Joined:
    Sep 23, 2005
    Location:
    below Ash Tree Lane
  8. macrumors newbie

    Joined:
    Aug 11, 2008
    #8
    Both methods work for me!!

    Thanks for this post it has really helped out. Just go us a Mac in the house and all my wife could say is it's slow because of the internet slow issue. She was right, but the methods in this post helped. I ended up going with the OpenDNS solution ultimately though.

    Thanks again
     
  9. macrumors 65816

    agentphish

    Joined:
    Sep 7, 2004
    #9
    yeh I notice a lot of ISP DNS servers blow. I don't like the comcast ones where I am. Nice tip, but there's lots of them out there.
     
  10. macrumors 6502

    PcBgone

    Joined:
    Feb 3, 2008
    #10
    I tried the opendns servers, and my pings went up by about 4ms, and my downloads went down by about 400Kbs...

    I went back to my isp dns, and was a lot snappier..
     
  11. macrumors newbie

    Joined:
    Sep 5, 2008
    Location:
    Canada
    #11
    DNS servers work

    Thank you for the tip, this really works. The only thing is that I have to restart the Apple router in the mornings to get connected.:cool:
     
  12. macrumors newbie

    Joined:
    Sep 25, 2008
    #12
    Thanks, works great

    Internet service was slow after an OS update. The steps you outlined worked a treat. Cheers!
     
  13. macrumors 65816

    aaquib

    Joined:
    Sep 11, 2007
    Location:
    Toronto, Canada
  14. macrumors member

    duckkg5

    Joined:
    Aug 14, 2008
    Location:
    Charleston, SC
    #14
    Yes!

    Yes! I did it and it works! Finally, fast internet!

    My settings looked a bit different - I've got 10.5.5 and it had some DNS server things already entered ... I just entered 4.2.2.1 and then 4.2.2.2 and clicked "apply" and all is well.
     
  15. macrumors 603

    Joined:
    Mar 29, 2008
    Location:
    Seattle
    #15
    Wowzers. This fixed my Qwest internet just great! I was having trouble with my new MBP and other OS X systems, but Windows XP Thinkpad was giving trouble. This fixed my Mac interwebs instantly! Great job!
     
  16. macrumors 603

    Joined:
    Mar 29, 2008
    Location:
    Seattle
    #16
    Looks like I spoke too soon. There's no question my Windows Thinkpad loads all web pages faster than my Macs. I'm on Qwest, and I think it's possibly Qwest to blame, but I'm not sure.

    Anyone else got any ideas about this? If I connect directly to the Actiontec modem or via my Time Capsule, it's still slow as all heck on all my Macs. :(
     
  17. macrumors 65816

    Joined:
    Jan 30, 2008
    Location:
    Wisconsin
    #17
    DNS servers have nothing to do with downloads... so it was all in your head.
     
  18. macrumors newbie

    Joined:
    Oct 20, 2008
  19. macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #19
    Directions and Screenshots for Leopard:

    1. Click System Preferences in the Dock

    [​IMG]

    2. Click the Network preference pane

    [​IMG]

    3. Make sure your your network interface is active (Airport for Me), click the "Advanced" button.
    [​IMG]
    4. Click the "DNS" tab, click the "+" button and enter both addresses then click "OK". ignore the greyed out DNS address its probably your router.

    [​IMG]

    5. Then make sure you click "Apply"

    OP's DNS addresses

    4.2.2.1
    4.2.2.2

    Open DNS addresses

    208.67.222.222
    208.67.220.220

    Open DNS will apart from speeding things up and keeing you safe from phishing will try to re-direct you to the right URL if you make a typo. if it cannot re-direct it will give you an Open DNS Google-like search of what you URL typed.
     
  20. Guest

    sangosimo

    Joined:
    Sep 11, 2008
  21. macrumors newbie

    Joined:
    Dec 18, 2008
    #21
    Thank you!!!!

    I've been searching these forums and trying to understand G vs N wireless rourters. :confused:

    I just did this and my imac is MUCH faster!! THANK you for your instructions AND PICTURES!
    :)
     
  22. macrumors 6502

    Joined:
    May 12, 2007
    Location:
    Springdale, AR
    #22
    Wirelessly posted (iPod touch: Mozilla/5.0 (iPod; U; CPU iPhone OS 2_2 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5G77 Safari/525.20)

    4.2.2.1 and 4.2.2.2 are what I have gears me called the public DNS, correct?
     
  23. macrumors newbie

    Joined:
    Dec 26, 2008
    #23
    How to THANK YOUUUUU!

    I have a mac Pro with dual core 3 GHz processors, 4 MB memory... and this machine made my life was absolutely miserable while navigating on the web. To the point that I was considering getting a PC to do my "Internet stuff", I CAN'T BELIEVE IT!!! it took this post and 5 seconds to have a super fast Internet!

    My PC fan husband can not teased me anymore!

    T-H-A-N-K-S-! :p

    PS. I have a ethernet conection.
     
  24. macrumors newbie

    Joined:
    Jan 3, 2009
    #24
    IMAC Running Leopard Only one week old

    I too am having the slow inernet connection with myMac. Everytime I get out of sleep mode and get on the internet I have to turn my airport off for a minute and turn it back on. Then my internet will work fine. My internet should be blazing fast, I have AT&T Fiber Optic Internet 2Wire. I tried the 4.2.2.1 & the 4.2.2.2 and that worked until I put my Mac into sleep mode again and took it out. Right now I just took out those two and added the open DNS servers 208.67.222.222 & 208.67.220.220. I am hoping this works, this is real frustrating having a brand new computer that crawls on the net.
     
  25. macrumors 6502a

    Joined:
    Oct 8, 2008
    #25
    I have an iMac. Is it necessary to put Open DNS addresses (208.67.222.222 / 208.67.220.220) for those who run Leopard or entering 4.2.2.1 and then 4.2.2.2 is enough?

    My speed connection is so poor..
     

Share This Page