How to force black to overprint background.

Discussion in 'Design and Graphics' started by dogbone, Sep 29, 2006.

  1. macrumors 68020

    dogbone

    Joined:
    Sep 16, 2005
    Location:
    S33.687308617200465 E150.31341791152954
    #1
    This is a continuation of a problem I thought was solved. I'm still getting black type knocking out a light background colour instead of overprinting after viewing pdf output from Indesign in Acrobat.

    If I use a photo it will overprint the photo if I set the advanced output option to "overprint preview" and it will knock out if I leave this box unchecked.

    However this checkbox seems to have no effect when I put type over a box filled with a background colour. However I have the checkbox set, when I preview the seps in Acrobat they always knock out, even though it does not knock out in the Indesign separation preview. I've spent hours on this this evening and I'm not getting anywhere.

    Should I just give the whole indesign package to the imagesetters and tell them to make it work or should I be able to output a pdf that views correctly in Acrobat?

    What is the reason for this inconsistency between indesign and Acrobat?
     

    Attached Files:

    • _07.jpg
      _07.jpg
      File size:
      72.6 KB
      Views:
      108
  2. Moderator emeritus

    Joined:
    Jul 4, 2004
    #2
    First thing: In InDesign are the Preferences>General>Print Options set to Overprint [Black] Swatch at 100%...?
     
  3. thread starter macrumors 68020

    dogbone

    Joined:
    Sep 16, 2005
    Location:
    S33.687308617200465 E150.31341791152954
  4. Moderator emeritus

    Joined:
    Jul 4, 2004
    #4
    Just as a troubleshooting step, have you tried printing postscript to disk and then dumping the resulting file into Distiller on a PDFx1a (or PDFx3 for spots) setting?

    If that's fine, then there could be something in your PDF export settings from InDesign which is causing the problems. What setting are you using to export your PDFs with?

    Are you using a TrueType font? According to Adobe, they can be the source of unreliable trapping in In-RIP trapping...

    Edit: they recommend converting type to outlines in these cases, maybe worth trying on a copy of the document to see if that has a bearing on things.
     
  5. thread starter macrumors 68020

    dogbone

    Joined:
    Sep 16, 2005
    Location:
    S33.687308617200465 E150.31341791152954
    #5
    OK, thanks, I tried all that. The distiller thing didn't help but converting to outlines worked as it *was* a true type font so that looks like where the problem is.

    However converting to outlines also made it look crap.

    Seeing as there is obviously no issue with trapping in this case I wonder if the imagesetter can force the type to overprint?

    EDIT:
    I tried it with an open type font instead but I'm still getting the same problem :mad: I'm using the standard print presets and I've tried the simulate overprint checked and unchecked. I've been through all the export options and I can see nothing that is relevent. Surely Open type should work?

    More EDIT:
    I thought that OpenType was the new you beaut standard and was treated by older rips as if it were postscript type 1, so I am mystefied why the problem persists even with OT fonts.
     
  6. macrumors G3

    iMeowbot

    Joined:
    Aug 30, 2003
    #6
    OpenType is a TrueType wrapper around what can be either PS type 2, or TrueType, fonts.

    On the other hand, OpenType was something that Adobe developed side-by-side with Microsoft, so at the very least their own software should get it right :rolleyes:
     
  7. thread starter macrumors 68020

    dogbone

    Joined:
    Sep 16, 2005
    Location:
    S33.687308617200465 E150.31341791152954
    #7
    UPDATE:

    After making a test file with a font that I know should be fine and still getting the knockout problem. I spent all day treating this as an Indesign export pdf problem until someone elsewhere suggested that I try printing one of the bad seps that Acrobat is showing...

    So I ran out the magenta sep which was showing knockout through my crappy brother printer and lo and behold it comes out without any knockout exactly as it is supposed to look! Even my crappy TT elcheapo font is running out a correct sep onto my non postcript laser printer!

    Therefore I seem to have an Acrobat 6.0.2 sep preview problem rather than anything actually being wrong. Also purely by some sort of cruel coincidence (and a bad rip probably) the imagesetters were also setting my files incorrectly so that black was being knocked out. ie they were running out the jobs so they looked like the bad preview that Acrobat was showing. They have since informed me that they have found a workaround.

    I hope the above made sense. Anyway I've posted a question on an Acrobat forum to see if this is a known bug. In case anyone is interested here is a link to a test pdf, it displays as black type knocking out the background in the sep preview in Acrobat 6, I'd be interested to know how the magenta plate looks in Acrobat 7 sep preview.
     
  8. macrumors G3

    iMeowbot

    Joined:
    Aug 30, 2003
    #8
    In Acrobat 7.0.8, nothing looks out of the ordinary. All and magenta, since you were curious:

    [​IMG]

    Is this what you were expecting?
     
  9. thread starter macrumors 68020

    dogbone

    Joined:
    Sep 16, 2005
    Location:
    S33.687308617200465 E150.31341791152954
    #9
    I suppose so. Your example is exactly how my printer prints out the magenta sep from Acrobat 6.0.2. But it's sure as hell not how it looks on screen in Acrobat. Onscreen the separation preview shows the black knocking out the background, it also shows the black knocking out in the preview of the advanced print dialog box.

    I guess now what I'd really like to see is a screenshot of the magenta plate using *Acrobat 6*.

    I've re download the same file you have used, as you can see it shows knockout but it prints without knockout.

    [​IMG]
     
  10. macrumors 68030

    apfhex

    Joined:
    Aug 8, 2006
    Location:
    Northern California
    #10
    This is a really interesting bug you've found.

    In Acrobat 7.0.8 the PDF displays correctly with overprint both in the regular view and in the Print dialog box. So I guess it's been fixed in version 7. As long as it *prints* alright, it's not so bad, is it?

    What I would do is print the separations to a PDF file and check to see that they're alright.
     
  11. thread starter macrumors 68020

    dogbone

    Joined:
    Sep 16, 2005
    Location:
    S33.687308617200465 E150.31341791152954
    #11
    Is this really a bug? That is what I'm wondering. Is seems like it but I still find it difficult to believe. I mean it's not exactly the sort of thing that is easily missed? So athough I can work around it now, I'm still curious to know if it is a bug or if there is some other reason for the anomoly. Here's the link (again) in case anyone has the urge to look at the magenta plate in Acrobat 6.

    No it's not bad at all, *now*. But it was bad before I knew because I spent two days fretting and trying different fonts and meticulously going through dialog boxes and asking questions on forums and so forth. But now it's no worries. I just run out the seps on my crappy little printer and hand them over with the job and I sleep well knowing that I won't get blamed if the imagesetters cock up.
     
  12. macrumors member

    Joined:
    Oct 2, 2006
    Location:
    bay area, ca
    #12
    In InDesign, try this: Go to window>attributes. check your overprint fill / overprint stroke settings.
     

Share This Page