how to make a separate subnet for my local network

Discussion in 'Mac OS X Server, Xserve, and Networking' started by karsten, Apr 10, 2011.

  1. karsten, Apr 10, 2011
    Last edited: Apr 10, 2011

    macrumors 6502a

    karsten

    Joined:
    Sep 3, 2010
    #1
    Hi, i've tried everything i can think of. i'm trying to make a separate subnet for my local network. it's only 2 computers, a desktop and a laptop. i have it assigned to the ethernet ports as 192.168.2.1 & 192.168.2.2 (desktop/laptop). my desktop has a wifi connection as 192.168.1.100. i want to be able to connect them with ethernet for transferring lots of files and have os x automatically use that connection instead of the wireless as it's slow. i've tried setting the network priorities in network preferences, and adding a route in the routing table but it keeps trying to use the wireless between the 2 computers. how can i do this? thanks for any help (ps i want the internet to stay active when i connect the ethernet)

    edit- i can kind of make it work by disabling the wireless on the laptop.
     
  2. macrumors regular

    Joined:
    Jan 12, 2009
    Location:
    London
    #2
    need a better description of what you have, a picture might help
     
  3. karsten, Apr 10, 2011
    Last edited: Apr 10, 2011

    thread starter macrumors 6502a

    karsten

    Joined:
    Sep 3, 2010
    #3

    internet
    |
    desktop[192.168.1.100 external] / [192.168.2.1 local]----laptop[192.168.2.2 local] / [192.168.1.103 external]
     
  4. macrumors 6502

    Joined:
    Mar 12, 2010
    #4
    From your desktop can you ping 192.168.2.2 and from the laptop ping 192.168.2.1?

    From the diagram and your description, the laptop doesn't have a wireless connection. So it's a bit puzzling when you say it keeps trying to use the wireless. How are you trying to copy files, using Finder? Try scp'ing using the ip addresses you gave, if the pings work.

    BTW, I've got my laptop with a 192.x.x.x address for the wired connection, and a 10.x.x.x address for the wireless. It's having no problems seeing both networks.
     
  5. thread starter macrumors 6502a

    karsten

    Joined:
    Sep 3, 2010
    #5
    the laptop has a internet connection to the same router as the desktop as 192.168.1.103. it's easier to disable that so i wasn't too concerned about it turns out when i do then the ethernet connection works. i thought either by putting the ethernet interface first in os x's priority list and/or making a route for it that it would work but neither seemed to do it.


    no pinging doesn't work
     
  6. macrumors 6502

    Joined:
    Mar 12, 2010
    #6
    Are both interfaces even up when you have them both connected? See what the status from ifconfig is, and if both interfaces have ip addresses.
     

Share This Page