How to make folders go to the top in list view

Discussion in 'macOS' started by millerrh, Dec 4, 2006.

  1. millerrh macrumors 6502

    Sep 14, 2005
    I've read many times people want to make folders appear at the top of a list in Finder like they are represented in Windows explorer. I found an article on Macworld that tells you how to do this.

    I remember doing this over a year ago on my G4 Powerbook and it working. But on my Intel MacBook Pro, I can't locate the file they are referring to in the article. Any ideas where this file was moved to or how to access this thing on the Intel machines?
  2. andyclimax macrumors newbie

    Feb 14, 2009
    LaunchServices.framework File on Macbook... Pro But Still No Solution

    I too followed the steps from the Macworld article successfully on my Macbook! But now I have a Macbook Pro I cannot find the LaunchServices.framework file. :mad:

    After an internet search I found the file here:


    And subsequently found the English.lproj file they were asking for:


    But don't bother! I added the mysterious space in front of the second "folder" and after a restart a few times, it still doesn't do what it is supposed to do.

    Go figure. :(

    Let me know if you find a solution! :confused:
  3. Ashka macrumors 6502a


    Aug 9, 2008
    New Zealand
    Just type a ~ before the folder name, many other symbols work to.
    A space as part of but before the folders name works too. You can actually name folders or drives for that matter with spaces.

    If you need to re launch finder, just hold down the option key and right click, re launch is on the context menu.
  4. D A macrumors regular

    Nov 21, 2008
    In Leopard it's in /System/Library/CoreServices/, then "Show Package Contents" and from there: /Contents/Resources/English.lproj/InfoPlist.strings. Add a space before the second "Folder" You may need to change permissions to be allowed to edit that file though.

    Relaunch finder and it should sort with folders on top.
  5. rocketeer85 macrumors newbie

    Nov 2, 2009
    I know this is a few months old now, but I think it's worth writing that this has worked successfully on my MacBook after a few searches of unsuccessful trying.
  6. professorjay macrumors member

    May 13, 2007
    Which method worked? And are you using Snow Leopard?
  7. Rob.G macrumors 6502


    Jan 17, 2010
    NW Oregon
    I tried the technique mentioned by D A but so far, nothing. This is what the line looks like that I modified:

    "Folder" = "Folder";

    So I changed it to:

    "Folder" = " Folder";

    Is that correct?

    After that, I put the perms back and rebooted. But folders are still interspersed with files.

    BTW this is on Snow Leopard.. 10.6.2.

  8. lostsync macrumors newbie

    Jul 27, 2010
    Seems to be some amount of confusion about this so...

    Steps to do this in 10.5/6:

    Open Terminal and enter the following commands

    cd /System/Library/CoreServices/
    sudo cp InfoPlist.strings ~/Desktop/InfoPlist.strings
    sudo mv InfoPlist.strings InfoPlist.backup
    sudo chmod a+r ~/Desktop/InfoPlist.strings
    open ~/Desktop/InfoPlist.strings
    Change "Folder" = "Folder" to "Folder" = " Folder"

    sudo mv ~/Desktop/InfoPlist.strings InfoPlist.strings
    killall Finder
    Now, sort finder by Kind and you're done

Share This Page