How to make magic mouse auto connect?

Discussion in 'Mac Peripherals' started by Storm9, Oct 30, 2009.

  1. macrumors member

    Joined:
    Dec 1, 2007
    #1
    If i turn off the mouse and on again, it wont auto connect to my MBP. I have the latest update.

    Other than that love the mouse!
     
  2. macrumors regular

    Joined:
    Feb 15, 2008
    #2
    u gotta click the mouse then it'll connect, other wise i don't think it will auto connect
     
  3. macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #3
    I was having the same problem with mine. So, after playing around a bit with un-pairing, and re-pairing, etc., I think I stumbled on a solution:

    Try turning off Bluetooth on your Mac, then back on. After I did this, I was able to cycle the Magic Mouse's power and then re-connect as expected with a click.
     
  4. macrumors regular

    intel

    Joined:
    Aug 17, 2005
    #4
    Here's a harder question for you.
    Say you switched the magic mouse off while logged in, then when you go to switch it back on you had the click squeezed while gripping the mouse to get to the tiny button.
    Now what? Mouse un pairs, goes into discovery mode and won't reconnect even when u switch it off and back on. You have no other mouse only keyboard. I can get into settings with keyboard. I can navigate to Bluetooth devices by typing into search and using tab but how do I navigate to the little plus (+) to re pair my mouse?
     
  5. macrumors newbie

    Joined:
    Jul 10, 2010
    #5
    When first switched on the mouse displays its battery status, so clicking won't initiate the connection. This gives you more than enough time to release your grip and stop clicking. After a few seconds, the mouse enters discovery mode (the little light on the back begins to blink) at which point you can click and the mouse should connect to the computer. Even if you're still gripping the mouse, letting go and clicking once more will enable the connection to be re-established.
     
  6. macrumors newbie

    Joined:
    Jul 27, 2011
    #6


    I have the exact same problem. What was your solution in the end? I'm new to mac. 2nd day and this happens. Please help.
     
  7. macrumors newbie

    Joined:
    Jan 14, 2014
    #7
    Just hit the down arrow once you get to the settings icon. once connect is highlighted, hit return and you're all set.
     

Share This Page