How to permanently stop programs at startup..

Discussion in 'Mac Basics and Help' started by Seanrobrien, Mar 25, 2008.

  1. macrumors newbie

    Joined:
    Mar 18, 2008
    #1
    How do I stop programs I don't want from starting when I boot up the system?
    I know I can do it after the programs are running but they seem to reappear after booting up again.

    Example: I have 2 HP Printer programs that I'd like to shut down so they stop using system resources.

    Sean
     
  2. macrumors 6502a

    spinne1

    Joined:
    Mar 12, 2005
    Location:
    Hermitage, TN USA (near Nashville)
    #2
    Go to System Preferences, then to Accounts, then to the Login Items tab. Check the box of anything you want to hide at login. Or, if you really know you don't want it, select it and hit the negative button to remove it.
     
  3. thread starter macrumors newbie

    Joined:
    Mar 18, 2008
    #3
    I tried that.

    It does not show any items in the box. When I go under utilities and system monitor it show a bunch of processes running that i want to shut down.

    Sean
     
  4. NAG
    macrumors 68030

    NAG

    Joined:
    Aug 6, 2003
    Location:
    /usr/local/apps/nag
    #4
    Yeah, HP doesn't use the standard way of including them in your accounts panel. They're bad unix citizens (and their software is junk). Instead they mess with your loginwindow.plist file in their infinite stupidity.

    To stop them from starting up you have to mess with that file.

    Library > Preferences > loginwindow.plist

    Note, this is the library at the root of the hard drive. You shouldn't normally be messing with anything in here, but you're going to have to since HP thinks they're special.

    Open it up with the plist editor (a text editor will also work but it will look messy).

    If all you see in it is HP stuff then you can go ahead and move the file somewhere else (put it somewhere and save it incase you need it again).

    Then restart.
     
  5. macrumors 68000

    Antares

    #5
    Great tip, NAG, this will really help me too!
     
  6. macrumors newbie

    Joined:
    Dec 14, 2011
    #6
    Are you aware that when you go to shut down, there is a checkbox that you must click if you don't want your apps automatically re-starting?
     
  7. macrumors newbie

    Joined:
    Feb 4, 2012
    #7
    Can't stop programs from loading at startup

    per comments on this blog I went to System Preferences but Accounts is not in my Preferences to uncheck any programs. I am running Lion, is it now somewhere else to access.

    This is a new iMac and for whatever reason at startup it loads about a dozen items. I have not been able to figure out how to stop this.

    Thanks for any help
     
  8. macrumors newbie

    Joined:
    Feb 24, 2012
    #8
    Can't stop programs from loading at startup

    Check to make sure programs are closed. If a white do appears below the program icon on the dock the program is still running. For example, if iTunes has the white dot below it open iTunes and then click on iTunes just left of the black apple. Click on "close iTunes: and this closes the program and it will not automatically open when you log in.

    ----------

    Correction-Click on iTunes just right of the Apple and close iTunes by clicking on quit iTunes.
     
  9. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #9
    There are a few places to look for startup items:

    Items can launch upon startup from the following locations:
    • System Preferences > Accounts > yourusername > Login Items
      (Lion users: System Preferences > Users & Groups > yourusername > Login Items)

    • /Library/LaunchAgents/ and ~/Library/LaunchAgents/
      (Lion users: In Finder, click Go > Go to Folder > then enter the path)

    • /Library/StartupItems/
      (Lion users: In Finder, click Go > Go to Folder > then enter the path)
     
  10. macrumors newbie

    Joined:
    Jun 12, 2012
    #10
    It is different. It's actually System Preferences > Users & Groups > Username > Login Items.
     

Share This Page