How to stop Console from recording non-events?

Discussion in 'OS X' started by Cubytus, Feb 5, 2013.

  1. macrumors 65816

    Joined:
    Mar 2, 2007
    #1
    Hello,

    I have activated OS X's firewall as a good security practice, but when Transmission is running, I get hundreds of these unuseful lines in the Console (with different IPs of course).

    Code:
    13-02-04 11:27:53
    Firewall[9156]
    Allow Transmission connecting from 176.27.xxx.yy:62564 to port 51413 proto=6
    It wouldn't be so much of an issue if I never used the Console, but for debugging purposes (Firewire disconnection issue inside), I left the console open for the past two weeks and as such, I need it to display only useful events.

    Notice Firewall is sending these records, not Transmission.

    How do I prevent such non-events to be recorded, i.e. stop "verbose" mode?

    Also, I have another recurring annoyance with the Firewall: even though some applications are set to automatically be allowed connection, they keep on presenting a popup to allow connection each time they're started.

    How can these application stop asking for a right they've already been granted with?
     
  2. macrumors 601

    talmy

    Joined:
    Oct 26, 2009
    Location:
    Oregon
    #2
    "One man's trash is another man's treasure." The console log is there to record all events, even those that are "non-events" to you! Use the filter to view only the events you are interested in.

    I haven't seen your second problem. Presumably the app in question is in the list under Firewall options to Allow Incoming Connections.
     
  3. thread starter macrumors 65816

    Joined:
    Mar 2, 2007
    #3
    Considering the application is already allowed for incoming connections, what owuld be the eventual practical use for reminding the user every 2 seconds?

    As for the second problem, all applications already allowed in the Firewall seem to do it, iTunes, SpiderOak, Transmission, etc. Can't find why.
     

Share This Page