How to: stop Finder opening after start up?

Discussion in 'OS X' started by John Purple, Feb 13, 2008.

  1. John Purple macrumors regular

    Joined:
    Jan 8, 2008
    #1
    Since installing Leopard the Finder window pops up automatically after staring my Mac. This didn't happen any time before (from System 1 to 10.4.10!). I hate it but I don't know where to change that setting.
    Does anybody know?
     
  2. MBX macrumors 65816

    Joined:
    Sep 14, 2006
    #2
    same here.

    i often experience this and just hate it.

    could it be happening when you leave a finder window open when shutting down?
     
  3. thesdx macrumors 6502a

    Joined:
    Jul 12, 2007
    #3
    It might be an application that's opening the window. Has this only been happening since Leopard?
     
  4. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #4
    Close all windows, then shut down. It saves your last state, so if a window is open when you shut down, it will reopen. You may also need to check the Finder Preferences.

    TEG
     
  5. waterskier2007 macrumors 68000

    waterskier2007

    Joined:
    Jun 19, 2007
    Location:
    White Lake, MI
    #5
    try looking in system preferences>accounts>login items, and see if finder is checked?
     

    Attached Files:

  6. John Purple thread starter macrumors regular

    Joined:
    Jan 8, 2008
    #6
    It happens as well when the Finder window is open as when the Finder window is closed before shutting the Mac down. That doesn't matter :(

    It never happened before installing Leopard.

    Closing the windows doesn't help. It will reopen at startup. I checked the Finder preferences but I found nothing that made a change in behaviour :(

    There is no line with the Finder. Only other applications that work well.

    Thanks but there should be another way (hopefully)
     
  7. John Purple thread starter macrumors regular

    Joined:
    Jan 8, 2008
    #7
    I just solved the problem by deleting the preference file 'com.apple.systempreferences.plist' from the user's library.
    :)
     
  8. Jrpars macrumors newbie

    Joined:
    Jul 4, 2008
    #8
    I'm having the same problem. Finder window appears upon startup.

    Have already checked the following:
    1. Finder does not appear in my log in items under user
    2. Have deleted the following files in user/library/preferences: com.apple.finder.plist; com.apple.systempreferences.plist; com.apple.loginitems.plist
    3. I've also tried closing the finder window and rebooting, closing the finder window and logging out/in, etc.

    This is really starting to bug me:( Any ideas?
     
  9. macusrngm macrumors newbie

    Joined:
    Jul 23, 2008
    #9
    Stop finder opening after startup?

    I found this in my login items

    Deleted the highlighted item and no finder window on the next login
     

    Attached Files:

  10. m1ss1ontomars macrumors 6502

    Joined:
    Oct 1, 2006
    #10
    Well, you had the Finder in your login items, so it opened on login.
     
  11. macusrngm macrumors newbie

    Joined:
    Jul 23, 2008
    #11
    Totally correct.

    Yes, you are totally correct.

    The mystery is how it got there.

    I do not remember this behavior before I upgraded to Leopard. After I upgraded; every time I signed in, I got the window on my desktop. I did not think to even look into my startup items since I had not modified it. It was not until I found this forum that I was alerted to look there. And; there it was.

    Not sure if the upgrade did it or not.
     
  12. pinktank macrumors 6502

    Joined:
    Apr 5, 2005
    #12
    it mightve assigned it once you shut it down with a finder open, might be one of those harmless bugs that go unnoticed/confused with common bheaviour
     
  13. zeket macrumors newbie

    Joined:
    Nov 21, 2008
    #13
    Got It!!

    what worked for me was this:

    Close all apps and windows
    Force power off by holding power button until it powered off.

    That's it!!!

    Gone
     
  14. commandnotapple macrumors newbie

    Joined:
    Jun 13, 2009
    #14
    Found a Fix

    I know this is an old thread, but I figure I should post this for posterity.

    Over at the Apple Support forums, I found this link:
    http://discussions.apple.com/thread.jspa?threadID=1425019&tstart=1703

    As a synopsis, this will fix the random Finder window opening at login:

    1) Go to: Your User Folder/Preferences/com.apple.finder.plist
    2) Delete it
    3) Control + Option click on the Finder in the Dock. Choose "Relaunch"
    4) Restart

    It was that simple for me. If it doesn't work for you post back and we'll try something else!
     

Share This Page