how to stop texts from being shown on home screen

Discussion in 'iPhone Tips, Help and Troubleshooting' started by larrymassive, Nov 14, 2007.

  1. macrumors newbie

    Joined:
    Nov 7, 2007
    #1
    Hi there i just noticed today that a text that my wife sent me was on full show when i had my iphone in sleep mode and was just wondering if there is anyway of changing this so the text can only be viewed if i open the sms option? Just seems silly if someone sends you a private text and you then say show a friend the phone because they would like to look at it but theres this private text staring them in the face. My old nokia would have the option for sms preview on the home screen but i had the option to turn it off so all my texts could only be seen if i went in to the text inbox

    i have looked everywhere for an option with no luck,

    cheers
     
  2. Moderator emeritus

    kainjow

    Joined:
    Jun 15, 2000
    #2
    The solution is simple: don't let friends use your iPhone :p
     
  3. macrumors 65816

    Joined:
    Feb 22, 2007
    Location:
    Southampton UK
    #3
    you wana tell your wife to stop sending dirty texts while you're with your friends. ;)

    Seriously though, I don't think you can turn it off. I know if you put a passcode on it (asks you to enter before you can wake it) you can turn it off there. But other than that theres no option.
     
  4. macrumors 6502

    Joined:
    Dec 16, 2005
    #4
    settings/general/passcode lock/show sms preview

    Easy as.
     
  5. thread starter macrumors newbie

    Joined:
    Nov 7, 2007
  6. macrumors newbie

    Joined:
    Dec 20, 2009
    #6
    For OS 3.1

    Try also settings - messages - 'show preview'

    Found this forum through a search engine and the menus on my phone are different, leaving this note in case any one else wanders in :)
     

Share This Page