How to turn on subtitles in iTunes

Discussion in 'Apple TV and Home Theater' started by lamhonlun, Oct 31, 2010.

  1. macrumors newbie

    Joined:
    Oct 24, 2010
    #1
    I have rip some movies with HandBrake including srt subtitles.

    I have no problem turning the subtitles on/off on my iPhone 4. But how can I enable subtitles on iTunes?
     
  2. macrumors 601

    tbayrgs

    Joined:
    Jul 5, 2009
    Location:
    Florida, USA
    #2
    When you're playing the movie in iTunes, hover your mouse over the picture and you should see an icon on the right hand side of the playback controls that looks like a text bubble. Select that and you can toggle subtitles on or off.
     
  3. macrumors regular

    Joined:
    Sep 7, 2007
    #3
    While we're on the subject, how do you select subtitles (and other audio tracks) on the new apple tv?
     
  4. thread starter macrumors newbie

    Joined:
    Oct 24, 2010
    #4
    I still don't get the text bubble even i hover my mouse to the control bar in iTunes.

    [​IMG]

    [​IMG]
     
  5. thread starter macrumors newbie

    Joined:
    Oct 24, 2010
    #5
    I am expecting you are referring to iTunes 9.2
    http://docs.info.apple.com/article.html?path=iTunesMac/9.2/en/20868.html

    However, I am using iTunes 10 and it does not show the text bubble even though I have checked the box of Show closed caption when available.
     
  6. macrumors 601

    tbayrgs

    Joined:
    Jul 5, 2009
    Location:
    Florida, USA
    #6
    I'm using version 10.1 as well. There is also an option to enable specific audio and subtitle tracks under the Controls drop down menu in iTunes. Is that available or is it grayed out? The closed captioning box shouldn't make a difference as I was able enable an .srt subtitle track with or without it checked.

    If the ability to enable it using the drop down isn't available, I'm out of ideas, sorry. Essentially it appears iTunes isn't recognizing the presence of the subtitle track--not sure how it's possible for the iPhone to see it if iTunes can't. Hopefully, one of the many experts here with more knowledge than I can help you out.
     
  7. thread starter macrumors newbie

    Joined:
    Oct 24, 2010
    #7

    Yes, the audio and subtitles option under control tab is not available. I have no idea why.

    But anyway, thank you for trying to help
     
  8. macrumors 6502a

    Joined:
    Dec 24, 2007
    #8
    Under Preferences in iTunes there is, under Playback, an option to choose the soundtrack and subtitle language.
     
  9. thread starter macrumors newbie

    Joined:
    Oct 24, 2010
    #9
    Indeed there are Audio and Subtitle options to select. Although I select the subtitle as English, but the sub still doesn't show up in the movie :(

    [​IMG]
     
  10. macrumors regular

    Joined:
    Sep 3, 2006
    #10
    The file extension needs to be .m4v if you want to see the subtitles in iTunes and QuickTime Player 7.
     
  11. macrumors regular

    thetaylor13

    Joined:
    May 14, 2010
    Location:
    Work
    #11
    I've got a .mp4 that plays subtitles just fine in Quicktime, yet in iTunes it won't play at all. Any thought why? Or should I just convert it to .m4v? And does Handbrake do that?
     
  12. macrumors regular

    Joined:
    Sep 3, 2006
    #12
    No, you should go in Finder and change the extension to .m4v.
     
  13. macrumors newbie

    Joined:
    Nov 8, 2011
    #13
    It's been a while and you've probably figured it out/given up, but I had the same issue you did and I just figured it out last night:

    I re-encoded the movie a second time w/ subtitles and could not get the subtitles to work. I then realized I had to delete the file from Itunes (not the original file, just the file from itunes!)

    You need to add the file back into itunes, which will take a few seconds to load. The subtitles should work after you do this. For me, itunes kept playing the previous file w/out subtitles which explains why it did not work
     
  14. macrumors newbie

    Joined:
    Sep 5, 2010
    #14
    I have also ripped some movies from DVD with Handbrake. I don't want to burned in subtitles. After conversion I can select subtitles in VLC, but not in iTunes, ATV or iPad. What's the problem?
     
  15. macrumors newbie

    Joined:
    Sep 5, 2010
    #15
    Any ideas?
     
  16. macrumors regular

    Joined:
    Mar 6, 2011
    #16
    Does the file you're using have a .m4v extension? If it's .mp4 then iTunes will not allow you to use subtitles. I've no idea why.
     
  17. macrumors newbie

    Joined:
    Jul 21, 2012
    #17
    I′m having the same problem. I had an mp4 file with no viewable subtitles. Then I changed the extension in Finder to m4v and now the movie plays in Finder (QuickLook), iTunes, VLC, Quicktime, but iTunes stil don′t allow me to choose the subtitles file (the option is greyed out)...

    Any ideas?

    Shoul I do a proper file conversion (not merly to change the extension to.m4v)?
     
  18. macrumors 68020

    Joined:
    Mar 15, 2012
    #18
    For the aTV to have the ability to turn subtitles on/off (soft subs) there has to be a subtitle track in srt format in the mp4. This can be done by downloading an srt subtitle file from various websites that provide them, then incorporating that file into the mp4 while transcoding with Handbrake or adding it manually using Subler.
     

Share This Page