How to type diacritics (special characters)

Discussion in 'macOS' started by akadmon, Dec 4, 2006.

  1. akadmon macrumors 68010

    Joined:
    Aug 30, 2006
    Location:
    New England
    #1
    Short of installing a localized version of OS X, is there any way to type diacritics on a Mac? I'm mostly intersted in Polish special characters: ą ę ł ó ś ż ż.
     
  2. psychofreak Retired

    psychofreak

    Joined:
    May 16, 2006
    Location:
    London
    #2
    I'm sure there is something better, but if you keep a .txt document with them, then you can copy the list of them to the top of every document, and just keep copying and pasting the ones you want, then, when you're finished, just delete the list. Not the simplest solution, but its what I do when I write my french essays for school.
     
  3. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #3
    Well, all copies of OS X will support any localization, as far as I know. If you were to set your first-choice language to Polish, your menus would appear in polish and so on.

    As far as how to make the characters, not all of those appear to be available via easy keyboard shortcuts on the US keyboard layout. This is what I would do:

    System Prefs -> International -> Input Menu
    Select Character palette and/or keyboard viewer from the list.
    Select one/both of the polish layouts from the list
    Select "Show input menu in menu bar" if it isn't highlighted.

    Now you get a flag in the bar. When it's on the Polish flag, you get the polish keyboard layout. You can use the keyboard viewer from that menu to see how to make different characters with the keyboard (i.e. if you open it and press option, you see what you get when you press a key with option). You can also use the palette to insert any character available in any font.
     
  4. akadmon thread starter macrumors 68010

    Joined:
    Aug 30, 2006
    Location:
    New England
    #4
    Thanks. I'll try this when I get home.
     
  5. akadmon thread starter macrumors 68010

    Joined:
    Aug 30, 2006
    Location:
    New England
    #5
    Hm. This seems to work on the fly in Safari, but when I'm in Word I default to the US keyboard no matter what. What's going on?
     
  6. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #6
    Mmm, I'm not sure. Word 2004, correct? When you changed those settings in sys prefs, there was also an option in the same place to set one language for all apps or to allow different apps to have different input languages / methods. Try changing the option you've selected (probably to "all apps") and see if this helps.

    Or do you mean that when you are in Word, even if you go to the input menu and change the selection to Polish, you still get US English?
     
  7. akadmon thread starter macrumors 68010

    Joined:
    Aug 30, 2006
    Location:
    New England
    #7
    I selected Use one input source in all documents, but the problem still persists. As soon as I put Word into focus, the Keyboard Viewer changes to U.S. This happens even when I have the U.S. Extended keyboard selected as my input.
     
  8. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #8
    Hmmmm... strange. You may have to independently define the document language as Polish in Word (tools -> set language, I think)? I haven't run across this...I can play around with it on my Mac when I get home, though. I didn't bring my iBook in today.
     

Share This Page